I can't make a file executable using terminal?

wine

#1

I wanted to play Nullpomino tetris so I downloaded the archive and I’m supposed to launch the .exe, but nothing happens when i double click on it. I found that chmod +x is supposed to be used but that doesn’t work for me either. I navigate to the right directory using cd command and then type chmod +x nullpomino but nothing happens. I also tried selecting “Allow executing file as program” but it doesn’t work. I also tried this with Tales of Maj’Eyal but I have the sam problem.

Please help. Thanks :smile:


#2

Sounds like you need to install Wine.


#3

See also:

https://www.playonlinux.com/en/

https://www.playonlinux.com/en/supported_apps-1-0.html

:smiley:


#4

I already have Wine, that is not the problem. These are apps made for Linux. Other people start them using chmod command. I wonder whether I’m doing it wrong or there is some bug in Ubuntu Mate? Do any other people have similar problem with executable files?


#5

If it’s an .exe file, It is for MS Windows.

You need to download this version:

http://nullpomino.googlecode.com/files/NullpoMino7.5.0_linux.tar.gz

Once downloaded, navigate to the compressed folder (it will probably be in your “downloads” folder) and double-left-click it to open it. Then extract the folder.

Then go into the extracted folder and double-left-click “NullpoMino” and choose “run” from the options.

I’ve just done all of the above and it works.