I did NOT "FORGET" my Password! Ubu DOES!

ISSUE: It's at the bottom so no one presumes a answer before they know the issue.

Been installing Ubu 18.04 and associated updates, and stuff since February 2018. This will be the fifth time I've had to re-install Ubu and all associated programs never mind lost files, which I've come to learn not to save since that seems futile.

I've read the novelettes online about how to change the password, restore it, recover it, but ONLY IF ONE HAS ACCESS! Duh! And, they are all about "What to do it you forget your password" Well, I didn't forget it. Never have I forgotten it nor forgot it.

I don't think random forgetfulness should be acceptable. Even the giant doesn't forget them. Nothing was changed. I hardly use the laptop /c Ubu because it I don't have the time to learn all the nuances. I just need it to browse the net, handle some email and look pretty.

So, why does it keep loosing the password? How can I change it without following the "Login with your password" then go to..... to change it"??? I CAN'T LOG IN!!!!

ISSUE:
Ubu keeps forgetting the password. Over 2 years, I've had to reinstall Ubu 5 times. It's that simple. I know the password, can type, can read, can see that caps lock isn't on, and didn't 'lose" it. Please stop blaming the end user for that one.

Thnaks in davance,
~i~

Do you mean the login password? Can you login via terminal if you ctrl-alt-f1 ?

You dont need to reinstall. You can just reset the password by following step 2 here:

After the short boot, I get the generic greenish login screen. - period. That is where it acts like windoze.

  1. I tried your tweak and held CTRL-ALT-F1 at start of boot - failed.
  2. Tried again, and again and last time, and assuming those keys should be pressed at the login screen, at login it went to "terminal".
  3. In terminal(?) mode:
    zinnersx9 login: | <--- blinking cursor and "zinnersx9" is user name
    Entering password and hitting ENTER, it then shows:
    Password: | <--- blinking cursor
    Now it says "Login incorrect"".

I also tried entering the user name at the first terminal "login" and then the password in second part, but same thing... incorrect. WRONG Ubu,

Please remember, I did NOT forget the password. Ubuntu did.

Thanks for your help pallebone - it is very much appreciated.
I'm sure charges can be filed for murdering a laptop so I'll go play Skyrim now instead...

~i~

Do you think the password is getting corrupted, not lost? Seems odd the password would be lost. Not sure how to get it back, but do you need to password protect your installation? Would autologin work? Personally I always set up a second account and give it sudo rights, in case I have login troubles with my main account. That way if I have a problem I can reach users and groups and the login window. I know that won't fix your current problem, but it could save you a lot of work. Before reinstalling I would run some diagnostics on the hard drive if I were you.

Another possibility is that the keyboard's layout had changed... is yours definitely set to the right one?

Screenshot_20200211_110058

As an example, the GB layout do swap the @ and " keys with the US layout. If you end up resetting the password from recovery, you'll want to also double check it's not using a different keyboard layout, if yours is different to en_US.

1 Like

If lah7’s idea doesn't work, just follow the reset instructions and you can set any password regardless how its gotten lost.

Check also if is CMOS battery is dead. Take out the battery for 5 minutes and put it back.Log in one more time. Good luck

1 Like

Just a thought. Provided that you know your password perfectly and it is not corrupted there is a possibility that the password has been expired. Huh?

Yep "Huh?" is just how I feel :slight_smile:
I will travel through Ubuntu tonight to see if that is what happened - but wouldn't Ubu warn the user that it's time to change?

Thanks ugnvs for the tip. I'll report back on what I find. But, I did follow someone's help and was able to reset the password.
~i~

1 Like