In caja, pressing 'y' key opens new tab. Can't rename files!

Hello to all,
While i was renaming some files in caja file manager, i noticed that as soon as i press ‘y’ key it opens a new tab. Because of that i cant rename files that contains letter ‘y’ anymore. Please help me fix this issue.
So far i have tried updating, fixing and repairing packages by using “Software Boutique’s” fixes option. I also tried finding keyboard shortcut for opening new tab in caja but didn’t find any. I have looked in “keyboard shortcuts”, and in “dconf editor”.
I am using Ubuntu mate 16.04.2 and caja 1.12.7 .
Any help would be appreciated. Thank you in advance.

That’s weird. I can’t reproduce this behavior on my 16.04.2 install.
Anyone else affected by this?

Maybe, i messed up some setting or something. How could i reset it to its default behavior?

Without knowing how it ended up in that state I don’t know.

sudo dpkg-reconfigure caja

sadly, didnt work. Any other commands that i could run?

Maybe we can get a vector to the problem…

  • This is unique to Caja and ‘y’ is fine everywhere else?
  • Caja’s File menu has ‘New Tab’ hotkey as Ctrl+T? Does Ctrl+T work, too?
  • Caja’s Edit -> Preferences has an Extensions tab. Does turning them all off help?
  • Keyboard Shortcuts - carefully examine if any are set to ‘y’ in the list.
  • Keyboard Preferences tab ‘Layouts’ has an ‘Options’ button. A rather large list but look for bold entries which indicates changes from default.

Here’s hoping something shows up.


Thank you Bill_MI !
New tab hot key was set to ‘y’.
I must have accidentally pressed ‘y’ while accessing file menu via ALT+F .
I changed it back to Ctrl+T.

Great! I love it when a plan comes together. :slight_smile:


Indeed, looks like it was accidental editing of menu item shortcut when “can-change-accels” setting was enabled:

In Dconf at /org/mate/desktop/interface/ I have no can-change-accels option there at all - does anyone know a command that will add it? I suspect this may be what's making it so hard for me to get keybindings to stick for Caja scripts I've created. After adding them to the script's entries in the accels file the effect should be immediate - but, while they will eventually stick - the keyboard shortcuts keep getting removed as accels refreshes itself, and I have to keep adding them back. It took 2 days of this for the last shortcut to finally get registered. (And yes, I removed the semi-colon and space at the beginning of the line, sometimes repeatedly)

I'm pretty sure the can-change-accels option was removed years ago, when Caja and the rest of MATE transitioned to GTK+ 3 from GTK+ 2. GTK is a graphical user interface library, and MATE uses it for all of its applications. In GTK+ 2 (and early versions of GTK+ 3), you used to be able to edit menu accelerators; the GTK+ 3 team removed that option in (I think) version 3.14, because, they contended, the GUI toolkit shouldn't be in charge of storing all these disparate menu accelerators for all these applications; the applications should be in charge of storing these accelerators.

I do not think that this has anything to do with your Caja script woes. Keep looking, and good luck.

1 Like

Yeah Gordon, I've been with Linux for 15 years, back in Gnome 2 and KDE 3, and I've seen "if it ain't broke, don't try to fix it" ignored repeatedly, and I couldn't even tell you why some of the features and ways of doing things were removed, or new ones implemented. But as for Caja's accels file, I can't wrap my head around why it doesn't work but then it finally does. It kind of drives me nuts - not so much the delay, but the logic (or lack of) behind it, not to mention randomness of timing - but the good news is if I define a shortcut it will eventually work, even if I have to keep going back in the edit the entry. (But this whole "just let her have a nice nap, and she'll feel better in the morning" of it really messes with my sense of logic and causality, hahaha!)

I replied in your other topic re: the accels file. It looks like Caja just doesn't look in the file unless you tell it to quit and reload, or else Caja may overwrite your accels file when you start navigating the menus or such. Try saving the file and then immediately opening a terminal and using caja -q. That's the gist of what I wrote over there, but do read what I wrote over in the other thread.