In case your keyboard still in qwerty at the login screen Ubuntu Mate lightdm


So if you’re in this situation that your keyboard dosn’t switch to you’re native language in login screen, i have found this way to fix, helped by the ubuntu french forum who might work also for otherslanguages. (only tried french setup)
Thanks to InspecteurHARRY for his help.
Please, think about saving original files in case it doesn’t work for you.
1 Create configuration file :

sudo mkdir /etc/lightdm/lightdm.conf.d

2 Inside of this lightdm.conf.d that you just made, create a file called 00-keyboard.conf

3 Then edit file named 00-keyboard.conf as follow : (in my case it’s setxkbmap fr, fr is the language (france) must be letters within your language choice)

display-setup-script=/usr/bin/setxkbmap fr oss

4 Reboot, you’re done

I just tried to translate, as i said i am not the person who solved this issue, so i really hope i don’t made much mistakes with translation.
To make sure, here is mine
You can see path in Caja :slight_smile:

Wish it help


Out of curiosity how did you run the installer?
Myself I’ve picked English as the install language, then “French / Legacy” as keyboard layout in the later steps.
I haven’t experienced any keyboard problems so far.

Well, i will make a quick virtual
machine and try to remember, but i can say that as with ubuntu unity i leave by default.
So this is maybe my “mistake” .
I do experience this with all login screen such as kdm, the xfce one (which is ?) no problem with gdm or Ubuntu default lightdm
(Logitech keyboard)
Thanks ouroumov, and i will try to give feedback about it, here (by seeing what option i chose)
Sorry for my english by the way …

Hi, thanks a lot it was very helpful for me.