In "mate-appearance-properties" fonts tab desktop font is greyed out

I am on Ubuntu 20.04 Mate desktop. I noticed that in mate-appearance-properties' fonts tab desktop font is greyed out and inactive, I can't select a font. I also created another user, it's the same in that login. I also ran it with sudo, nothing is changed.

Is caja (the official MATE file manager) installed?

sudo apt install caja

If not, then you can't really expect a MATE configuration tool to be able to configure a third-party file manager's preferences. (On any normal MATE desktop, Caja would be in charge of drawing the desktop background and icons.)

@gordon Thank you for responding. Yes, caja, is my default file manager. I also asked it on myaskubuntuquestion. I reinstalled ubuntu-mate-desktop but it didn't work.

I can set Desktop Font with gsettings set org.mate.caja.desktop font 'Sans Regular 10' but it's not updated in "mate-appearance-properties's fonts tab I think mate-control-center can't reach it or it stems from a broken schema in my system.

I traced backwards, and the mate-control-center code will gray out the Desktop Font button only if the Caja settings schema is inaccessible.

Try the following:

sudo apt reinstall caja

Then close any Appearance Preferences windows and re-open the Appearance Preferences, and see if you get a functional font button.

Hi Gordon. Out of interest, any idea what would cause this?

@gordon I'm grateful to your effort. I did what you instructed, it didn't work. I created a new user, it didn't work either. I also renamed /usr/local folder to prevent conflicts with manually installed libraries.

I can set Desktop Font with gsettings set org.mate.caja.desktop font 'Sans Regular 8' but it's not updated in "mate-appearance-properties 's fonts tab, it's still showing Sans Regular 12 in greyed out state.
I also tried Ubuntu Mate Live ISO it works well.
I just don't know how to track it down.

Weird. So when you use the gsettings command, does that actually change the font on the desktop, or does nothing happen there either?

Either way, try:

sudo glib-compile-schemas /usr/share/glib-2.0/schemas

...then open the Appearance Preferences again. I've seen some occasions where applications get installed or uninstalled and for one reason or another, "forget" to inform applications that they've installed new settings.

The only thing I can think of is if the user or the administrator was a moron (like I've been on occasion over the years) and changed permissions on every file on the entire root file system. Like this:

# Do not do this:  sudo chmod -R o-rwx /

Other than that, I don't know why that in particular would happen.

1 Like

Yes, that command takes effect and it changes the desktop font.
I can read it via dconf read /org/mate/caja/desktop/font
it prints 'Sans Regular 8'

I still don't know what triggered that bug but I fixed it reverting changes which committed in 2014.
With that commit Use Caja GSettings schema optionally caja's function became optional.
I downloaded mate-control-center's source code from original repository with
apt source mate-control-center, I opened files and inserted or deleted required lines.
Then dpkg-buildpackage -b -rfakeroot -us -uc and installed deb packages on desktop with sudo dpkg -i *.deb

mate-appearance-properties is OK now.

Thank you @gordon, @UbuntuMetal and Ubuntu-Mate-Community