Incorrect clock display in Ubuntu MATE 22.04


This is probably a problem only for the Polish version of Ubuntu MATE 22.04, otherwise it would have been corrected otherwise.

Please take a look at what the clock display in the upper right corner looks like:


The year (insted of the hours) and the minutes is displayed. After changing indicator settings and turning on seconds display it looks better (hours:minutes:seconds) but after displaing calendar there is still 2022:17 (year:minutes).

How to correct this?


1 Like

there is a date/time applet-- I think in Control Center. Make sure the time is set automatically be set. Its worth a try, I'm at work so can't verify the above - Change Date & Time - Learn Ubuntu MATE

IMHO it is a bug in the system :frowning:

My settings:

Zrzut ekranu z 2022-09-23 20-49-11

Sorry, only one image in the post (I'm new). Indicator settings:

Hi, @marcinkk .

I've done some web searches and I think you're right: it seems to me that you are being affected by the following Bug / Issue for the "ayatana-indicator-datetime package" that was reported for Ubuntu Mate 20.10 (but that I see in the comments of that Bug page that is still affecting Ubuntu MATE 22.04), for the Poland / Polish Locale (LC_TIME=pl_PL.UTF-8):

The user that reported that bug (Robert Bycul), on 30th November 2020, wrote the following text in the "Bug Description" section of that page, which includes a way for the user to "fix" the issue by issuing some "gsettings" commands or to use "dconf-editor" with the same settings:

" Bug Description

The time applet on the panel displays time as: "YYYY:MM", YYYY being 4 digit year and MM 2 digit minute (see the attachment, the panel there is vertical, but doesn't matter, the issue is observed in horizontal panel too).
It looks as if it wanted to display both date and time instead of just the time, and probably it is trimmed because it's too long, so that only beginning and end of the date-time string is displayed.
(Localization: Poland, Time zone Europe/Warsaw).
The only way to fix it is to issue the following commands:
gsettings set org.ayatana.indicator.datetime custom-time-format '%H:%M'
gsettings set org.ayatana.indicator.datetime time-format 'custom'

(Of course it can also be fixed with the dconf-editor with the same settings). (...)"

I hope those "gsettings" commands also solve the problem for you :slight_smile: I also suggest that you click on the "This bug affects 3 people. Does this bug affect you? " link in that Launchpad Bug #1906238 web page (in order to add yourself to the list of affected users by that bug) and you may also want to add a comment in that page to report your experience with Ubuntu MATE 22.04 LTS ("Jammy Jellyfish") regarding this bug.


Thanks for information about official bug report.

Clicked to increase number of affected :slight_smile:

I've changed the mentioned settings in dconf-editor and ... it is only the partial solution, like activating display of seconds. After change it looks like below (time below calendar):


PS. I don't know what changed in the locale settings, but a month ago I had a problem with displaying the time in moodle after upgrade to 4.0. It was necessary to change some string formats in Polish translation.

1 Like


I don't know if it is corrected in the newest Ubuntu MATE, but on the most recent 22.04 the problem exists. But I found the source of this error...

I've started with: ayatana-indicator-datetime/po/pl.po at main · AyatanaIndicators/ayatana-indicator-datetime · GitHub

There is a little strange:
#~ msgid "%H:%M"
#~ msgstr "%G:%M"

It is disabled, but I searched my system and in the I found this problematic "%G:%M". I've decompilded mo, modified po, then changed file and rebooted. After this change 24-hour time is displayed correctly.

Kind regards,

1 Like