Incorrect scaling, multiple displays (19.10, 20.04)

I've been using Ubuntu Mate 19.10 for at least a half year, and everything was perfect until 2 weeks ago I updated all packages (apt update && apt upgrade). I suppose that it was some big update, because a lot of packages got new versions, my display drivers were updated, after restart I had to enroll mok before booting the system, etc.

But here comes the problem: after this update a lot of interface items became much smaller. I can see that running application icons on my top bar became smaller, their number was increased and the fonts became much thinner. And while for the most applications nothing really changed (maybe fonts became a very little bit smaller), some applications became impossible to use. For example all elements and fonts in my JetBrains IDEs became so small I can't even read them at all. I contacted jetbrains support, but it looks like it's some kind of a system issue.

Worth to mention: I use laptop (HP envy 15.6", 1920x1080, GM108M [GeForce 930M]) and an external Dell monitor (27", 1920x1080). If I unplug my external display and then reboot - everything becomes normal. Moreover, if I plug in my external monitor after system is booted - everything is also OK.

Since I didn't change any configuration, I'm 100% sure that the last update was the reason of the issue. That's why I'm looking for a way to restore my previous state.

I also tried:

  • Switching secure boot on and off
  • Changing drivers version (NVIDIA 440, NVIDIA 435, NVIDIA 390)
  • I even updated to 20.04 LTS when it became available

But none of the above helped. Right now I have to boot without my external display plugged in and plug it in after the system is booted, I can live with that, but it's very confusing.

This is just an idea on my part - but as no-one else has replied ...

Have you checked HiDPI setting in MATE Tweak? It defaults to Auto-detect and if it is selecting a different value when external monitor is connected than when it isn't it might be a possible cause?

Try changing it to Regular, ie. non-HiDPI. If no difference, I'd try HiDPI as well. If display is same in all cases then you can set it back to Auto-detect because that isn't your cause.

Hope that helps.

It helps but in a very strange way. Once I opened mate tweak for the first time, it was "auto-detect" selected. I changed it to "regular", and it fixed the problem. But! After the reboot, the problem returned. I went to the mate tweak again (thinking the settings were not saved), but they were. "regular" was the selected option after the reboot. So I changed it to "auto-detect" and the problem was fixed. Again. Although the last time it was fixed by changing from auto-detect to regular. So now every time I reboot my laptop I have to go ti MATE tweak and change the value, no matter to what, I just need to change it to a different value.

It looks like an obvious bug for me. I can of course live with it, it's not a critical issue, but it is an issue anyway. Is there any place where I can submit a bug report or something?

Report bugs to You will need to obtain a login to

And No, I don't know why the bug reporting and tracking location is no longer featured on this website somewhere prominent ...