Install driver for Xerox 3025 scanner not working

The below driver works on Ubuntu mate 18.04.1 only for printing.
The scanner application does not see the scanner.
On Ubuntu 14.04.5 (32 bit) the same driver worked just fine.
I tested the driver on Ubuntu mate 18.04.1 on 32 and 64 bit with firewall on AND off, but NO luck.

I installed the driver by unpaking it and right clicking on and run as administrator.
When the question about the firewall got printed in terminal, I tried with autoconfigure and with skip. I couldn't make the scanner work.

Than you.

PS. Pity that I discovered Ubuntu mate just now :slight_smile:

Hello marius-ciclistu

The information in this post may help you:

You may consider the license to be a worthwhile investment (have a look at the details, you get quite a lot for your money).
Good luck. :slightly_smiling_face:

Thanks, but I have Xerox not kodak.
If there isn’t a solution for my problem, i’ll dual boot in ubuntu 14 or windows to scan, and that’s it.

Hello marius-ciclistu

If you had used the link to the “hamrick” website and looked around about a bit you would have found this:

Is that your machine?
Good luck. :slightly_smiling_face:

Thank you.
I was discouraged by the “trial” word as I already payd the workcentre that cammed with the drivers (only that the guis from XEROX had no clue how to install the linux driver and I had to dig online to find out.

Solved the issue with this solution:

I used pluma instead of vi when editing that file.

I did not ran sudo adduser $USER lp

Hello Marius, i would like your assistance in setting up my Xerox Workcenter 3025, I have the same issue, i can not install the driver package for the scanner (the printer is working just fine), could you explain to me in steps what should I do.

Hi. There is a link to the solution above. What seems to be the issue?

After you install the xerox driver by runing from the official driver archive,

Run in terminal: sudo ln -sfr /usr/lib/sane/* /usr/lib/x86_64-linux-gnu/sane
This will create a symlink for the folder /usr/lib/sane/ in the second location.

Then, I updated the file /etc/sane.d/xerox_mfp.conf using the command
sudo pluma /etc/sane.d/xerox_mfp.conf
by adding the following two lines:

#Xerox WorkCentre 3025
usb 0x0924 0x42da

I saved and closed the file. And finally, reboot.

hello, I am new in Linux, i tried to run in terminal those lines but after reboot my operating system forced me to install a fresh copy of the Linux.
Could i get in touch with you on e-mail? could i call you on phone? I am from Romania.