Install the whole graphical environment (and maybe more!) again

Hey there! I’ve got a big problem here and I REALLY need your help. A few days ago I’ve installed some dependencies that Steam required to start on my girlfriend’s notebook (with Ubuntu MATE 15.10) and when I did, everything started to uninstall (including stuff like cryptsetup, mate-core, firmware-linux and vital stuff like that, it was awkward because they had nothing to do with these dependencies that I’ve installed).
Now I cannot start the system normally (only in console mode booting from recovery) and I need to start it normally (you know, with a graphical environment and that) to copy my girlfriend’s important stuff located in ./home before reinstalling everything. This stuff is really important for her and man, I don’t want to ruin her christmas telling her that I cannot recover her documents, photos and videos. Thank you in advance!

Important: I’ve already tried to copy her home folder using the console mode (sudo cp ./home/cinthia /media/TOURO-1TB/cinthia) but I couldn’t, and that’s why I need the graphical environment.

Put the Ubuntu Mate iso on a USB stick and load the computer as a live user with that USB. This will allow you to graphically navigate to the home folder on the laptop. Copy all of the files from there to another USB stick. Then reinstall the whole thing onto the laptop with the live USB you used to load the laptop with. It will be faster than trying to identify and then repair the damage done to it,

1 Like

Well, that’d be amazing, but it’s imposible because the disk is encrypted. :frowning:
I could recover the graphical environment (desktop), but there is another problem now, when I tried to mover the home folder from the command line (/home/cinthia) it moved it somewhere else and now I cannot access Cinthia’s account. I guess I’d need to log in as root and move the folder back to the home directory, or better, move it to the external disk. So: how do I access as root?

If you log in as a live user, the root has no password, i believe. So, if you are at a terminal and you type:

sudo su

You will be automatically taken to root in the terminal.

Similarly, I am guessing that if you open a terminal in a live session and type

Sudo caja

This will open the GUI caja file manager window as root. Thus allowing you to access and copy any files on the disk.

I could be wrong about all the above, but it is what I have read.

1 Like

gksudo caja :slight_smile:

If I start as a live user I will not be able to access the disk, because it’s encrypted with a password. Is there a program that I could install on the live user session to access to the encrypted disk typing its unlock password?


using a NETWORK CABLE CONNECTION, run "dpkg" per the guide and see if that helps!:

1 Like

Thank you to everyone for the help! I could fix it. Here’s what I did:

I started from a Linux system without graphical environment. Just console. To fix this, I’ve installed some packages that I thought important (ubuntu-mate-core, mate-core, mate-desktop and cryptsetup).
That helped in pretty much nothing, because I couldn’t log in even as guest.
I had to boot on recovery mode, select the dpkg option to mount the filesystem as rw and then, open the root console. I’ve copied the folder I’ve wanted to copy to the root directory, and then booted with a live image and accessed the encrypted disk putting the password it has.
Oh, and I couldn’t access to the files, because they had the wrong permissions, so I had to restart again in recovery mode. Using the root console, I used chmod -R ugo+rwx and rebooted. I could copy everything!

I’ve tried other stuff that I didn’t mentioned here, but the important part is the solution, right?

Thanks again for all of your help.