Install Ubuntu-Mate on Windows Intel Compute Stick?

Hello All,

I have one of the Windows Intel Compute Sticks, and now that Ubuntu-Mate 15.10 is out, I’d like to wipe and re-install the stick.

Can someone please link me a set of instructions on how to do this (or tell me it’s as simple as plugging in a boot stick)? I have had no luck from my duckduckgo-fu.

Also, I heard that the wireless driver wasn’t in the mainline kernel previously. Has that changed? Is it in 4.2, or are their special instructions on getting that working?

Thank you

1 Like

I must get one of these to test with!

Installing Ubuntu-Mate 15.10 on an Intel Compute Stick (Windows 8.1 with Bing version)

Intel Compute Stick Model BOXSTCK1A32WFCR
Connectland 4 port powered USB 3.0 Hub
USB Mouse
Dell USB multimedia keyboard with unpowered 2 port USB 2.0 hub builtin
D-link DUB-1312 USB 3.0 to Gigabit Adapter
Dell 2408WFPb monitor (has HDMI inputs)

you need to access the bios first and change the operting system from Windows 8.1/10 32-bit to Ubuntu 14.04 LTS 64-bit. Thats how I could start seeing other USB boot devices.

To access the bios you have to be quick on the buttons, or else the stick starts booting.
If you don’t see it fast enough:
F2 gets you into the BIOS
F7 gets the BIOS update utility
F10 gets you the boot device prompt
The moment I see and lights on the keyboard, I start tapping the key for the function I need.

I updated the Bios to version 0030 from a microsd card
The Stick belongs to my work, so I need to be able to get windows back on there is needed.
So I want to make an image of the current setup before I proceed.

I have Symantec Ghost available to me (Windows PE), and normally it just works, but this time the boot options don’t see any of the Ghost

sticks I plug in (USB 2 || 3).
I swear even though the Secure Boot is off, it’s still rejecting unregistered OSs. I can boot off of my Windows 7 and Ubuntu-Mate 15.10 usb

sticks. Maybe related to USB 2.0 vs 3.0, but I think it just doesn’t like the Ghost boot system.
So now I’m trying Clonezilla Live. 179MB download. Sweet, I can use a 256MB USB stick that’s been laying around forever.
The USB stick was recognized and has booted.
I don’t have an SD card big enough, so I’m going to store the image to the network. Clonezilla recognized the USB network adapter and DHCP

seems to have worked.
I created an NFS share on a test FreeNAS system I was working on.
Whoops made a mistake on the nfs mount point. Need to learn how to access an NFS share now.
Well that was a runaround trying to get either an NSF share or CIFS share to work (non-existent mount points my butt)
I accepted the Basic mode and imaged the whole disk. (3 partitions)
Everything imaged and restorable (we’ll see)
Approx 7.77 GB image folder created

End part 1

1 Like

I am able to boot off the ubuntu-mate 15.10 amd64 stick with no problem. Chose the install right away option. Gui installer popped up properly.

I noticed that the wired/wireless weren’t connected. used the dropdown in the top-right corner to select Auto Ethernet, and that seems to have gotten the dongle going. continue.

Selected to install updates + 3rd party software while installing. continue.

opted to erase whole disk. continue.
drive selected is MMC/SD card #1 (mmcblk0) 30.6GB MMCS10032. Install Now.
parition 1 will be ESP, partition 2 will be ext4, partition 3 will be swap. continue.

where are you? continue.
keyboard layout? continue.
who are you? (darn numlock isn’t on by default, bah) continue.

off we go. (I’ll buy a beer(or beverage of choice) for whomever came up with the “Ubuntu + Mate + Heart” = Ubuntu-Mate logo sequence, great logo)

Isn’t that nice. I’ve booted into a large gray screen. Hmmm, What did I miss?

End part 2.

Screen is light gray with a 25 pixel dark gray border around the entire screen. No mouse pointer evident. Like it is the background you see before the login prompt appears.
No link lights on the Ethernet dongle.
There are multimedia lights on the keyboard, but the capslock and numlock lights do not respond.
Tapping the power button does not seem to register.
Holding the power button does turn off the stick.
Booted up again.
Selected Advanced options for Ubuntu.
edit the grub line to remove splash,quiet
continued booting and got the login screen.
rebooted and the system booted naturally.
tried to login, password failed. ??
tried to login again, password failed. ???!
slowed down my typing, password failed. !???!
used a hunch, login successful.
Capslock was on during password creation.
Now where do you change that? Ok, got it.
What do you mean, old and new passwords are too similar!?
Grumble, Grumble.

logged in, did some updates. System seems to be running fine.
Wireless is not detected, and I don’t think the audio is there either.
system monitor shows 4 cores, and all 4 hit 70% when playing a 720p youtube video in firefox.

Have to see about finding those drivers.

End part 3.

Oooh, keep these coming :slight_smile:

There is one with Ubuntu! The problem is that has only 1GB RAM and even worse 8 Gigabyte eMMC.