Installation of Epson WF 3620DWF on Ubuntu mate 16.04

Hi there,
I have problems installing my new printer WF 3620DWF on Ubuntu mate 16.01.
I just don’t get the epson drivers installed. Does anybody have a link or instruction ‘for dummies’?

thanks a lot in advance


I installed this very same printer for my mom earlier today (her Epson WF-4535DWF died last week). I installed just the printer driver and scanner support, no Epson Printer Utility nor the fax driver (she doesn’t have a landline).

First download drivers from Epson:

Give “3620” as the model and select Linux from the Operating System dropdown.

Printer driver: select the ESC/P-R Driver (generic driver), currently version 1.6.12. When presented with different file options, pick epson-inkjet-printer-escpr_1.6.12-1lsb3.2_amd64.deb for 64-bit version, epson-inkjet-printer-escpr_1.6.12-1lsb3.2_i386.deb for 32-bit.

Scanner driver: select “Scanner Driver” (currently versio 1.0.4) and in the next view go to “>> Package Download Page” where you can pick deb package for 32 or 64 bit.


Make sure you have package lsb installed (it pulls in lsb-printing, which is needed for support of third party printer drivers). Scanner support needs sane (libsane) installed as well, but it should be installed by default.

Install printer driver (in terminal):

sudo dpkg -i epson-inkjet-printer-escpr_1.6.12-1lsb3.2_amd64.deb

Install scanner driver (in terminal):

   tar xaf iscan-bundle-1.0.4.x64.deb.tar.gz
   cd iscan-bundle-1.0.4.x64.deb

And that should be it.

Edited to add: if you want to install the Epson Printer Utility, I guess it’s just a matter of downloading the deb package and installing it with dpkg -i.

1 Like

Hi samuvuo- thank you for your quick answer. I think now, I installed it all right. Everything worked- I could print and I could scan with xsane. But after some time the printer didn’t react. I was reading a lot in the internet and found that maybe I have to give a permanent IP adress to the printer, which I am not able to… with the router menue it’s not possible - do you know about this issue? Actually, the printer isn’t found even though it is in the right wifi net and last night it worked perfectly…

cheers, Linda

Yes, using a static IP for the printer will make everything more stable and your life easier.

Do you have the Epson Network Guide? If not, you can download it from here. It’s a zip package, you just need the manual.pdf that’s inside.

In the router’s admin interface look for DHCP settings (most likely in LAN settings, not Wifi) and something like “IP pool starting address”. In other words: a place where you can tell DHCP to start assigning IP addresses from up (for example) so that you can use the first eight IP addresses ( - as static IP addresses.

Decide what IP to use for the printer. I’ll use in this example, assuming that your router is

In your printer’s control panel navigate to the Wifi settings (use the manual.pdf as a guide). You will need to set the IPs in your printer:

Gateway (router):
Printer IP:
Network Mask:

Once set up, you should probably turn the printer off, then on again. Then test if the printer is visible to other machines in the same LAN by pinging the printer from your computer: ping -c5

If you could not find the DHCP range settings in your router’s admin interface, please tell us what make and model your router is.