Installation problem - Ubuntu Mate 18.04.2 - Raspberry Pi 3B+

Hi,
I want to start using Ubuntu Mate on my Raspberry Pi 3B+, but I have a problem with starting in for first time. Pi is on, pluged to a monitor and the SD card with UM image is in, but the screen is all the time black. The red light is constantly on and the green one is flashing from time to time (without any pattern to distinguish).
With different memory card (with Raspbian) Pi is working normally.

I use:
-Raspberry Pi 3B+,
-Power Supply: 5V 2.5A,
-Memory Card: Kingston MicroSDHC 32 GB, Class 10, UHS-I / U1.

I appreciate any kind of support.

Sounds as if the image (wherever you got it) isn't properly loaded, and isn't able to boot (at all).
We expect the SD Card to be organised in (at least) 2 partitions -
one is FAT, the other ext4 - have you the tools and knowledge to check on the partitioning and the content files?
Derek

Unfortunately, I have neither of them.

What tool did you use for formatting your memory card with Ubuntu mate? Seems like a issue with the filesystems. If you're on Linux as your primary desktop pc, I recommend "restoring" the image with Gnome Disk Utility

I'm on Win 10. I've used Windows default format tool to format a SD card and balenaEtcher to burn an image on it.
So, I understand that I need a third party program to format a SD card properly. Does something like MiniTool Partition Wizard is good for this job?
(I've never used this before, I've only found out that something like this exists.)

I'm not sure about W10, only Linux so sorry ;(

If i can't use Windows 10, can I format my SD card with Raspbian?
Are there any tools to format memory card on this OS?

Yes, you can use GNOME Disks on Raspbian! However, of course you'll need some type of adapter to format the SD card while already having one in there. Although you really should switch to Linux.

Hello, it seems I'm having a similar issue.

Here's what I did:

  • Downloaded the xz file from ubuntu's site, and I even verified the checksums:

ubuntu-mate-18.04.2-beta1-desktop-armhf+raspi-ext4.img.xz

  • Used sudo gnome-disks to restore the .xz image to an SD card.

  • This gives me two partitions on the SD card:
    system-boot
    writable

  • I did all of the above in Raspbian.

  • In Raspbian, I am able to see and edit the files on system-boot. However, I get this error when trying to view writable:

Error mounting /dev/sdd2 at /media/pi/writable:
wrong fs type, bad option, bad superblock on /dev/sdd2, missing codepage or helper program, or other error

Wondering if something was wrong with the SD card, I did a full reformat of the SD card using FAT32, and then i wiped that out and re-did it all, with the same error. The image won't boot when I try to use it.

Any guiding comments are appreciated. Thank you!

I yesterday was battling with a somewhat similar problem:
on the first sdcard I found I could load OSMC and it wouldn't boot.
I therfore tried the same thing on another card, and it booted OK.
On the first card I tried an older version of OSMC no joy with booting.
On the first card I then tried the Ubuntu-mate 18.04.02 - which worked.

I assumed, having always been able to see the files after loading the card, that there nust have been a critical area which wouldn't take the correct binary pattern.

If you don;t have added tools with which to investigate, you have to move to a diferent sdcard. I can't think of anything to help except checking the partition table for the 2nd partition entry. If that is OK, then there must be a 'marker' in the filesystem area which isn't showing the correct value (but I'v never looked into checking this)

HTH