Installing a canon prixma mx700 network printer

hi all
noob to linux and having a VERY hard time getting my network printer to work. It worked under win 7 ( used canon drivers for windoze) but under linux nothing. It’s got a static ip address of which I can ping from my Ubuntu Mate 15.04 box BUT when I try to add printer using that ip address I get the message that there is no printer at that ip address. It’s a canon multifunction mx700 and I don’t think canon make linux drivers for it. ANY help would be appreciated

I found a couple of forum threads on the main Ubuntu site that appear to possibly have a solution for your question. Check out the links below. The first one has directions in the second post. This was asked for version 12.04 but I would hope it still is a working solution.

Forum Post 1

Forum Post 2

1 Like

Hey Cauterize
thank you so much for your reply BUT I already tried these approaches and no luck. I will certainly try again just in case I messed up Again thanks for your help


Hi Cauterize
Nope didn’t work.

I downloaded the zip file and extracted it to a new folder on the desktop called mx700
went into terminal to run the install script and I got the following (see bottom).

did a little digging and ran
sudo apt-get install libcups2 libcups2-dev
re ran install script and I managed to get it installed!!! bit of a struggle but…

NOW I can’t install the darn thing in the ADD PRINTER dialog I see the printer ( ip address) select the correct drivers and get to the “Describe Printer” dialog. when I try and add it the system asks to select a user and password which I do and I hit authenticate and it just keeps presenting the authenticate dialog box, I know I am entering the correct information and the user selected is an admin???

canonmx700.ppd cnijfilter-common_2.80-1_i386.deb cnijfilter-mp520series_2.80-1_i386.deb cups-bjnp-0.5.5 install README
dave@adams:~/mx700$ sh
[sudo] password for dave:
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package libcupsys2
E: Unable to locate package libcupsys2-dev
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package libcupsys2
E: Unable to locate package libtiff4
Selecting previously unselected package cnijfilter-common.
(Reading database … 270980 files and directories currently installed.)
Preparing to unpack cnijfilter-common_2.80-1_i386.deb …
Unpacking cnijfilter-common (2.80-1) …
Setting up cnijfilter-common (2.80-1) …
Selecting previously unselected package cnijfilter-mp520series.
(Reading database … 270988 files and directories currently installed.)
Preparing to unpack cnijfilter-mp520series_2.80-1_i386.deb …
Unpacking cnijfilter-mp520series (2.80-1) …
Setting up cnijfilter-mp520series (2.80-1) …
Processing triggers for libc-bin (2.21-0ubuntu4) …
checking for a BSD-compatible install… /usr/bin/install -c
checking whether build environment is sane… yes
checking for a thread-safe mkdir -p… /bin/mkdir -p
checking for gawk… no
checking for mawk… mawk
checking whether make sets $(MAKE)… yes
checking for gcc… gcc
checking whether the C compiler works… yes
checking for C compiler default output file name… a.out
checking for suffix of executables…
checking whether we are cross compiling… no
checking for suffix of object files… o
checking whether we are using the GNU C compiler… yes
checking whether gcc accepts -g… yes
checking for gcc option to accept ISO C89… none needed
checking for style of include used by make… GNU
checking dependency style of gcc… gcc3
checking whether make sets $(MAKE)… (cached) yes
checking for cupsDoRequest in -lcups… no
configure: error: CUPS library not found
make: *** No targets specified and no makefile found. Stop. 9: ./bjnp: not found
make: *** No rule to make target ‘install’. Stop.

Any way you take a screen shot of the authentication box? Is it authenticating to install the printer or is it asking for credentials to connect to the printer? This is on a home network correct? I would guess it is due to the network used.

My experience with printer is either usb connected at home or at work using it via samba. Are you choosing “find network printer” under the network printer drop down?

1 Like

Hey Cauterize
thanks again for the follow up BUT when I went back it was WORKING!!! here’s what happened I followed the link you sent me, which was different to the one I found and went through the instructions. All seemed to go well but at one point it asked me to select a user to authenticate the adding of the printer. I would select my admin user enter the correct password and it would loop back to asking me to authenticate. SO I tried a few times and then cancelled out thinking it was something else I had forgotten. I sent out the email to you and read your reply to take a screen shot. When I went into the machine ( remotely) the printer was set up and I was able to print to it. SO not sure what happened there but all is well thanks to your GREAT HELP thanks so much people like you help noobs like me so much

Well good to hear. The force is still strong with my troubleshooting powers it appears. LOL Hope everything else is going smoothly for you.

1 Like

Thanks again Cauterize, really helps a lot to know you are out there. Right now I am still muddling along but smoothly isn’t a word I would use :slight_smile: thanks again