Installing Android Studio on Ubuntu Mate?

I'm trying to install Android Studio on Ubuntu Mate on a Raspberry Pi 2. I got Android Studio to download but on installation I'm getting this error message.

Unable to run mksdcard SDK tool
One common reason for this failure is missing required libraries
Please fix the underlying issue and retry

I went to Google the error code and tried a few things. This StackExchange and DeveloperSite thread supposedly has some solutions.

Those dependencies will not install though. When I try to install it says.

Package has no installation candidate

I want Android Studio and not just Android Tools. I'm doing a course and want the entire program.

Anyone have recommendations or advice?

The Odroid by Hardkernel is a much better platform for Android development than the Raspberry Pi platform.

The Odroid-C2 has a 1.5Ghz Cortex-A5 3-core processor, 2Gbytes of DDR3 SDRAM, and Gigabit Ethernet. It can be ordered with Ubuntu 16.0.4 or Android 5.1 pre-installed on an EMMC card for just a few dollars more than a Pi3 – but much faster.

And if that’s not powerful enough for your development needs, there’s the XU-4 with a choice of 8-core Exynos5422 Cortex A15 2Ghz or Cortex A7 Octa core CPUs.

It results in a pleasurably speedy desktop experience that shows up the Pi3 as a laggard. I have a C-2 with which I’m very satisfied, so I speak from experience.

Thanks for the info on Odroid. I’ll consider getting a unit.

Right now I’m trying to see if Android development is something I’d like to do.

So any suggestions for getting Android Studio working on Ubuntu Mate are greatly appreciated.

I set up Android Studio a year or two back, under debian-jessie (or maybe it was wheezy). Then i never got around to doing anything much with it. But i do remember that you need the SDK tools. Mostly i’ve forgotten the details. Important thing imo is that Android Studio does work under linux, there was nothing specific to distro in the install process, and i installed the whole thing outside of the root partition (though not in /home).

There’s a checkbox somewhere, a list of checkboxes that let you choose what parts of Android Studio you want. If you have not chosen “SDK Tools” or something like that, then it doesn’t install them and you’ll get the message you got.

Their installation instructions are kind of limp, installilng it is a PITA, basically, but it can eventually be accomplished. I’ll be installing Android Studio again, but haven’t yet, by the time i get around to that point of development who knows what version of linux or Android Studio will be current.

Once you get it installed, i suggest that you read Google’s documentation relating to how to “capture” customers and hold them captive. I used to like Google more before reading that part, but sometimes it’s good to know more about what they want to achieve.

1 Like

Thanks @crankypuss.

I thought I would just mess around with Android Studio to see if I can become a proficient Android dev. I agree the installation instructions could be much more clear.

Lol, I’ll read Google’s documentation. Acquiring users and customers can be hard.

I don’t see an option for specifically installing SDK Tools on the installer. Maybe it was just on an older version? Can I install SDK Tools in Terminal?

Only way i could answer that is to set it up again myself, my memory is just that bad. I don’t even remember if it was packaged as a .deb file or a .tar or what… i downloaded the latest version (at that time) and did what was next. Eventually i got something working. Go figure, eh? Good luck, the more you want something the harder it gets. :slight_smile:

Yup. :slight_smile:

Not buying a Mac so this is my best option for app development right now.

Still haven’t found a solution. Would greatly appreciate any tips or suggestions.

Install ubuntu-make via the Software Boutique, it is a command line utility to install software development environments. It includes Android Studio, I think.

(Note that once you’ve installed ubuntu-make the command to find out how to use it seems to be “man umake”.)

umake seems to have installed, but although the manpage says android-studio is the default for android, “umake android” causes:

> umake android
ERROR: A default framework for category Android was requested where there is none
usage: umake android [-h] {android-ndk} ...

and “umake android-studio” generates:

 > umake android-studio
 usage: umake [--help] [-v] [-r] [--version]
         {ide,go,games,scala,dart,rust,web,swift,nodejs,android} ...
 umake: error: argument category: invalid choice: 'android-studio' (choose from 'ide', 'go', 'games', 'scala', 'dart', 'rust', 'web', 'swift', 'nodejs', 'android')

All i can figure is that either i’ve demonstrated a need for remedial reading (again, which is likely), or some dependency is missing, or who-knows-what. Has anyone ever used ubuntu-make to set something up? I’d never heard of it before.

This article says,

“Ubuntu Make is a command line tool which allows you to download the latest version of popular developer tools on your installation, installing it alongside all of the required dependencies (which will only ask for root access if you don’t have all the required dependencies installed already), enable multi-arch on your system if you are on a 64 bit machine, integrate it with the Unity launcher. Basically, one command to get your system ready to develop with!”

Doesn’t seem to deliver the goods to idiots. Note that it did not demand sudo privilege, and when i ran it as sudo it generated the same results. :shrug:

1 Like

Thanks for investigating.

Installed Ubuntu Make and not it seems Android Studio still will not install. Still get;

Unable to run mksdcard SDK tool.

Error code...

Did that, still giving the same error.