Installing Ubuntu Mate (latest version) via dvd on G4 MDD

Hello, the boot dvd is freezing once it gets to the welcome screen or before. does anyone know if I can install from disc? I had burned the disc at 4x should I reburn it at 1x?

Are you using 16.10 and booting into the live CD environment?

It could be possible the freeze is caused by the Welcome screen, as 16.10 has a “blank screen” bug. (16.04 does not have this problem)

Otherwise, when you can enter parameters at the boot: screen. Try this:


This should boot straight into the installation wizard and bypass the desktop.

Ok, so you don’t think re-burning the disc is really the problem. I will try only-ubiquity but I think I already did that but may have added agpmode=-1 to the end of it so I will try again. I have downloaded UNetbootin and am currently trying to copy the ISO to a flash drive although I am not sure if this computer can boot from USB or not. We shall see. If only-ubiquity does not work what would you try next?

I personally don’t think re-burning the disk will help, but you can try. The medium of the disc matters too (e.g. DVD+R will perform worst than a DVD-R)

I’m not sure of your system – which G4 system? (What’s MDD? :confused: ) Are you trying to install 16.10 or 16.04? How much RAM does it have?

Not enough RAM can be another possibly to freeze, but graphics are also be a culprit for PowerPC.

On an old iBook G4 I haven’t touched in ages, 12.04 and 14.04 were the “best” versions that worked well with the iBook G4, but there is no Ubuntu MATE versions available. Depending on the Mac you have, USB booting may be hit or miss. I couldn’t get it to boot from USB, and that’s the “NewWorld” Mac firmware.

I don’t really know much more about PowerPC. Somebody else will know a solution. :slight_smile:

MDD Refeers to the Models w/ a Silver reflective “Mirror” Drive Doors infront of its Disc Drives.

I’m trying to install 16.04.1 on a PowerMac 3,6 with maxed out RAM. Perhaps I should try an older version of Ubuntu Mate?

I tried only-ubiquity. It got me to the install(superuser) screen with the languages and then froze. Messing around with trying to boot from usb stick and open firmware but that seems like a can of worms. Doi need 2 partitions on the usb stick? Ugh, i really want ubuntu mate on this machine but kind of hitting a wall here.

If I yaboot live video=ofonly radeon.agpmode=-1 I can get to the desktop and if I am quick and close the welcome screen I can get terminal open. It seems as though once I start messing with the GUI things freeze. Is there some command I could run in terminal that might give us more information or allow me to trigger the installation bypassing the GUI?

You could try the Ubuntu Netboot CD (for powerpc 32-bit) and install the bare minimum needed for a functional system.

  • This CD installs in a console environment and will require an Ethernet connection to work.
  • There will be an option to install the "Ubuntu MATE Desktop" or simply "MATE Desktop Environment" which will get the goodness from MATE.

Although this could be a bit tricky since you need to pass commands to yaboot in order to bring up the GUI (once installed).