Internal or External Microphone not working!

Hey guys,

I have been searching and doing everything I can for the last three days but for some reason I cannot use either the internal microphone on my laptop or if i connect earphones with a mic.

I recently installed the Ubuntu Mate 16.04.1 and I am in love with it.. I have an ASUS X540S when i go to sound preferences all I see in input devices is "Monitor of Built-in Audio Analog Stereo" as an option and that is it!

Please help me out fix this as i don't want to move away from ubuntu mate.. its the best OS ever..

Regards,
Mazin Asif.

Ok now somehow I finally see an input option of:

“Built-in Audio Analog Stereo”

Along with that there is a new field above it which says:

Connector: “Microphone”

But still I don’t know how to get it working… HELP GUYS :slight_smile:

BUMP!!! Help… anyone??

I don’t know… Check if sound is unmuted in checkboxes (in Sound Preferences) and volume-levels are OK.

Last step: See if your hardware works in another distro. If it does see if your settings are the same in Ubuntu MATE.

Make sure correct hardware is selected in hardware tab in Sound Preferences.

  • Sound is unmuted in checkboxes and volumes are also OK.
  • hardware works fine, checked on windows. I cannot install another distro just to check the microphone.
  • Correct hardware is selected.

Can you please help out or anyone?

What should I do?

You don’t have to install another distro, just boot another distro in Live mode without installing. That’s what I would do.

Tried it still not working… Guys can someone help out? Where can i get Ubunte mate help from? I came here because this is the official community… please help out if someone can :slight_smile:

Didn’t sound work in another distro? Then chances are your hardware is not compatible with Linux. Maybe a more technical user like @ouroumov , @anon42388993 or @lah7 can help you out and see if your hardware is recognized by the Linux kernel.

Don’t give up. Ask for help in other places too, like askubuntu.com
The good thing about using an Ubuntu-based distribution is that you can search for help in a lot of different places and forums. Also google your hardware+Linux which might give you quick info about compatibility.

Oke..... we are going to try something here.
Open the Terminal Ctrl +Alt+ t and type alsamixer
It looks approximately like this,

Go with your arrow key -> to Mic, if this is a empty bar...then type m , if you do that you will see under the bar it will change from MM to OO.
It has to be OO. than go with your arrow key ^ all the the way up in the red zone.
It looks something like this,

That will do the trick.....

1 Like

Thanks bro! still trying to figure this out… sigh haha.

Hey! Thanks for the reply.. well the thing is i already tried this as well before i posted this thread.. but in my alsa mixer i do not see any mic/microphone anything :S.. although weirdly in the start even pulsemixer was not recognizing any microphone.. after a few days pulsemixer started showing microphone as an input but it still does not work.. i tried unlocking and bringing left and right volumes to 0 as well.. still to no avail..

This is what my Alsamixer looks like:

Hi @Mazin_Asif. The mic may show only when you press F4 to see the “Capture” controls. Note how the upper left has help and also displays the selected control in detail.

2 Likes

Hello again @Mazin_Asif, It´s like Bill_MI mentioned, there are more options to extend the settings.
So…can you go back to the alsamixer and press F5 for the full display of settings.

1 Like

I’ve just upgraded to 16.04 an have run into the same issue on a Asus Eee PC 1011PX.

AlsaMixer does not register an internal microphone at all (there is no bar displayed for ‘internal mic’.

arecord -l shows:

card 0: Intel [HDA Intel], device 0: ALC269VB Analog] Subdevices: 1/1 Subdevice #0: subdevice #0

Any ideas? TIA.

After 4 year, is there any solution?
I have same problem with Intel product on Ubuntu Mate 20.04.

arecord - l shows:

**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: 92HD81B1X5 Analog [92HD81B1X5 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0

Microphone can't capture any sound. Any idea how to solve this?