Internet Lost After Upgrade

I just upgraded to 17.04. My internet connection appears broken, I can’t use Thunderbird or Firefox. The message for TBird says it can’t find the server. I am using a wired ethernet connection. Things are working with Zorin so this must be an upgrade related problem. It was working fine on 16.04.

Thanks, Michael

can you post ifconfig and route -n ?

Sure, here you go:

[email protected]:~$ ifconfig
enp3s0 Link encap:Ethernet HWaddr 00:1e:90:6a:ed:f4
inet addr:192.168.1.5 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::298:d3f9:baed:dd1b/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:882518 errors:0 dropped:0 overruns:0 frame:0
TX packets:518154 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1306905329 (1.3 GB) TX bytes:38263743 (38.2 MB)
Interrupt:16

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:594 errors:0 dropped:0 overruns:0 frame:0
TX packets:594 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:72682 (72.6 KB) TX bytes:72682 (72.6 KB)

[email protected]:~$ route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 192.168.1.1 0.0.0.0 UG 100 0 0 enp3s0
169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 enp3s0
192.168.1.0 0.0.0.0 255.255.255.0 U 100 0 0 enp3s0
[email protected]:~$

Thanks,

Michael

this looks good … can you ping outside?, eg. ping -c3 google.com

There was a networking issue in 17.04. The following link should help get you going. It covers wired connections also.

https://ubuntu-mate.community/t/wifi-issue-in-17-04/12622/15?u=steven

I had the same problem a week ago
It is so simple to make it to work again.
Just boot to the previous kernel and reinstall the latest.
To do it first shutdown your computer.
Keep pressing the shift button while you open your computer and the grub menu will appear.
Select advanced options and select the second kernel NOT THE RECOVER MODE press enter.
Open the terminal and type
sudo add-apt-repository ppa:teejee2008/ppa
sudo apt-get update && sudo apt-get install ukuu
open ukuu from the menu and find the latest kernel and remove it
type in the terminal
grub-update
reboot
open update manager and upgrade everything

Sorry, I don’t know what you mean by that. Could you be more specific?

yes, I asked if you could enter that command in a terminal to see if you can reach internet. The same could be tried using Firefox and go to a website. @steven and @konmal88 suggested to boot with a previous kernel and try that. Maybe there was an issue with 17.04

Thank you, pavlos_kairis. I wondered if that is what is what you meant, I should have tried it.

I will try it soon (on another OS now). I’ll also try steven’s suggestion.

Also, I don’t suppose there is a way to roll back to 16.04?

Try these commands in the terminal:

sudo service networking restart
sudo service network-manager restart

and tell me if this worked!

OK, I tried “pinging” in terminal to get online. that didn’t work.

I then tried the restart network commands from knomal88, those didn’t work either.

I am thinking of trying to restore 16.04 from a Clonezilla image I made a few months ago. Although I have not successfully restored a Clonezilla image thus far.

Back on UM 16.04, after successfully restoring image with Clonezilla. No problem now with Internet. Thread can be closed, thanks to all who helped!

Michael