Internet not working after upgrading to Ubuntu 16.04

I’ve recently upgraded my ubuntu version from 14.04 to 16.04. Now
none of my internet connection work (neither ethernet or wifi), although
both are recognized in the ‘network connections’ panel. I verified that
both work with other devices.

I’ve searched for previous posts but none of them helped me…
some introduced slightly different problems (e.g., networks are not
recognized in the panel / only wifi doesn’t work etc…), or solutions
that require ‘sudo apt-get’ installations that use packages from the web
(which, obviously, I can’t download).

I would greatly appreciate any assistance. I am a simple user, so please be gentle :slight_smile:

Thanks a lot in advance,

Can you please provide the output for the following command:

sudo lshw -C network

Hi @Dimka :slight_smile:

Try this in the terminal. Press F12 for the Tilda terminal or CTRL+ALT+T for normal one.
If you want to copy+paste, hold CTRL+SHIFT+V in terminal to paste it.

gksudo pluma /etc/NetworkManager/NetworkManager.conf

And change managed=false to managed=true, press Save, go back to the terminal and type:

sudo service network-manager restart

Hope it helps. This should find all your networks and let you use them :slight_smile:

Thank you both very much.

WhyAreLess -
After asking for an admin passwoed, "pluma" doesn't do anything for me . I entered the file you mentioned using gedit, and the parameter "managed" was already true. I tried to re-save the file and restart the network-manager, but it didn't help. I remind you that my network connections are all recognized, I'm just not able to connect to any.

ouroumov -
A screen shot of the output is attached:

Thanks a lot in advance for any help


So yeah, I've been seing a massive amount of problems lately with Realtek ethernet cards using that particular driver.
Regressions are a pain.

For your WiFi, I googled around a bit and found something we can try:
You're gonna create a file to pass options to the iwlwifi driver loading process.
In a terminal type:

sudo gedit /etc/modprobe.d/iwlwifi.conf

And add in this line:

options iwlwifi 11n_disable=1

Then save, close the file and issue these two commands:

sudo modprobe -r iwlwifi
sudo modprobe iwlwifi

Thanks a lot,
I edited iwlwifi.conf according to your suggestion, and now it looks like this (seems like the file already has some lines that remind your suggestion):

I saved, ran the two commands, rebooted but nothing has changed - wifi still doesn't connect.

Any other suggestions?

Uh, I didn’t expect there to be anything in that file. Can you remove all except the options line you just added?

So I left only this line in the file.

After running
‘sudo modprobe -r iwlwifi’
I got the message
‘modprobe: FATAL: Module iwlwifi is in use’

Then I ran
‘sudo modprobe iwlwifi’ and rebooted…
Still wifi doesn’t connect.

Well, let's try for a cable connection then.
In at least one instance on this forum a connectivity issue was resolved for ethernet/r8169 using those two commands:

sudo modprobe -r r8169
sudo modprobe r8169

You don't have to reboot, if it doesn't work a reboot won't help.

Doesn’t work either :frowning:

Hi Dimka

Could you post the output of the following terminal command:

inxi -S


@Dimka Just to let you know. Ubuntu has a nice screenshot app which let’s you create screenshots so you don’t have to make a photo’s with your phone. The tool is called Screenshot, but whats in a name :wink:


I don’t have inxi installed so I can’t use that command. Since I have no internet, I can’t apt-get install it. Can I run another equivalent command instead?

Regarding the screenshots - yeah… but since my laptop doesn’t connect to the internet, I use the phone to post these replies anyway, so taking photos is the easiest option for me anyway.

Any other suggestions?
Thanks a lot!

I'm providing some more information just in case it can be found useful:

Ah, forgot about that one :frowning:

Can you try (with cable plugged in):

sudo ifdown eth0 && sudo ifup eth0

Then if it doesn't work:

sudo dhclient eth0

The first command resulted in ‘unknown intrtface eth0’

I ran the second command, and now wired connection works, Woohoo! Thanks a lot!!!

Few issues still remain:

  • When I plug the ethernet cable out and in again (or suspend/reboot the PC, I guess), the wired network doesn’t reconnect just like before. Connection is established only after I stop this automatic attempt and run ‘sudo dhclient eth0’ in the terminal one more time. How can I make this connection automatic?
  • How can I make wifi work?

Sorry for bothering you again guys, but this is really crucial for my work.
Any suggestions?

You know, Ubuntu 14.04 LTS is supported for three more years if you need your machine to work.

OK, so I figured it out and fixed the problem.

All I had to do is run ‘sudo apt-get -f install’ to fix damaged packages.
At first it didn’t work due to some errors in my tex-live package.
An error led me to the file ‘/etc/texmf/web2c/updmap.cfg’ where I had to comment out the first line (referring to a non-existing file). Then, ‘sudo apt-get -f install’ worked and solved my network issue.

Now both wifi and ethernet are working properly. Thanks a lot for all the helpers!

1 Like