Is anyone running Private Internet Access VPN with 15.04?

I was able to get it working on Arch (from AUR) and Fedora (not as easy), but I failed to get it working on Mate 15.04. After many attempts I reinstalled 14.04, and it worked on the first try. I was just curious to know if anyone was successful doing this on 15.04. If not, I guess I will be using 14.04 for awhile.

Yep VPN working fine here on MATE 15.04. What’s not working for you in particular?

It would not connect, but if it is working for you then I might have messed up something in the process. It is encouraging to know that it is possible. There are many people having problems with it on Ubuntu, and the site gives instructions for a very old version. I will try again. Thanks.

Thanks again, Zane. I reinstalled 15.04, and it worked.

You are welcome, i was about to reply to offer some clues. I am glad you got it working.
Tip: Make sure UFW is on configured to deny outgoing / deny incoming and is allowing out traffic through tun0 only. If you need help with that let me know.


I could use some help with the firewall. I am doing some research on that.

Generally it is good practice to couple VPN + UFW and good configuration, you are set to go. Use the below as a rough guide to get started.
Note: The below will block all traffic but traffic going through tun0 (VPN Tunnel Virtual Interface), if VPN drops your device will not have internet access which is effectively the purpose of this set up to prevent leaks. Should this not fit your privacy requirement then use Gufw default settings Deny incoming allow outgoing and that is it.

sudo ufw status 
sudo ufw enable
sudo ufw default deny incoming
sudo ufw default deny outgoing
sudo ufw allow out on tun0
sudo ufw allow out on eth0 to (Only needed in Home / Office Mode this will allow traffic to the router/internal network which in this case is located on If your computer has multiple network interfaces you can add the interface which you want to use  i.e sudo ufw allow out on wlan0 to  

Now you need to tell UFW to allow connection to your VPN sever (s)and relevant port number (s)

sudo ufw allow out to **vpn serv ip** **port number** proto tcp or udp    

Now you need to tell UFW to enable routing all traffic from your computer / laptop through the OpenVPN server.

Using your favourite text editor (Gedit, Pluma, etc) complete the following steps:

Forwarding Policy.

Open Terminal and run:

sudo pluma /etc/sysctl.conf
# Enable packet forwarding 

UFW Configuration

sudo  pluma /etc/default/ufw

UFW Before Rules

sudo  pluma /etc/ufw/before.rules

Change /etc/ufw/before.rules to add the following code after the header and before the “*filter” line

# NAT table rules
# Allow traffic from OpenVPN client to eth0 and wlan0

Registering the above changes in UFW

sudo ufw disable && sudo ufw enable  


sudo ufw reload` 

You will be able to see the firewall rules through Gufw or though Terminal.

sudo ufw status verbose`

Obviously, you will either be using your VPN provider’s VPN application or you are using OpenVPN to connect from your computer whichever method .

Hope this helps.

1 Like

Thanks for the detailed instructions.

No worries, hope it helps.


How to get vpn serv ip and port number for PIA VPN. They have many servers but there are no IP information.