Is the items in the following terminal window now broken?

I should NEVER run things such as this when I'm half asleep. I was installing LibreOffice from .deb and I forgot to change directories to my ~/Downloads/office directory. Instead I ran the command in ~/Downloads where there are several .deb files. Here is the output from my procedure:

[email protected]:~/Downloads$ sudo dpkg -i *.deb
Selecting previously unselected package boinctasks-js.
(Reading database ... 295753 files and directories currently installed.)
Preparing to unpack boinctasks-js_1.3.3_amd64.deb ...
Unpacking boinctasks-js (1.3.3) ...
dpkg-deb (subprocess): ZSTD_decompressStream error : Corrupted block detected 

dpkg-deb: error: <decompress> subprocess returned error exit status 2
dpkg: error processing archive boinctasks-js_1.3.3_amd64.deb (--install):
 cannot copy extracted data for './usr/lib/boinctasks-js/boinctasks-js' to '/usr/lib/boinctasks-js/boinctasks-js.dpkg-new': unexpected end of file or stream
Selecting previously unselected package chrome-remote-desktop.
Preparing to unpack chrome-remote-desktop_current_amd64.deb ...
Unpacking chrome-remote-desktop (108.0.5359.33) ...
dpkg: warning: downgrading conky-manager from 2.4 to 2.4~136~ubuntu16.04.1
Preparing to unpack conky-manager_2.4~136~ubuntu16.04.1_amd64.deb ...
Unpacking conky-manager (2.4~136~ubuntu16.04.1) over (2.4) ...
dpkg: warning: downgrading google-chrome-stable from 109.0.5414.119-1 to 106.0.5249.103-1
Preparing to unpack google-chrome-stable_current_amd64(1).deb ...
Unpacking google-chrome-stable (106.0.5249.103-1) over (109.0.5414.119-1) ...
dpkg: warning: downgrading google-chrome-stable from 106.0.5249.103-1 to 81.0.4044.129-1
Preparing to unpack google-chrome-stable_current_amd64.deb ...
Unpacking google-chrome-stable (81.0.4044.129-1) over (106.0.5249.103-1) ...
Preparing to unpack mate-polkit_1.26.0-1_amd64.deb ...
Unpacking mate-polkit:amd64 (1.26.0-1) over (1.26.0-1) ...
Preparing to unpack XnViewMP-linux-x64-2.deb ...
Unpacking xnview (1.4.0) over (1.3.1) ...
dpkg: warning: downgrading xnview from 1.4.0 to 1.3.1
Preparing to unpack XnViewMP-linux-x64.deb ...
Unpacking xnview (1.3.1) over (1.4.0) ...
More than one copy of package google-chrome-stable has been unpacked
 in this run !  Only configuring it once.
More than one copy of package xnview has been unpacked
 in this run !  Only configuring it once.
dpkg: dependency problems prevent configuration of chrome-remote-desktop:
 chrome-remote-desktop depends on xvfb; however:
  Package xvfb is not installed.
 chrome-remote-desktop depends on xserver-xorg-video-dummy (>= 1:0.3.8-1); however:
  Package xserver-xorg-video-dummy is not installed.
 chrome-remote-desktop depends on xbase-clients; however:
  Package xbase-clients is not installed.

dpkg: error processing package chrome-remote-desktop (--install):
 dependency problems - leaving unconfigured
Setting up conky-manager (2.4~136~ubuntu16.04.1) ...
Setting up google-chrome-stable (81.0.4044.129-1) ...
Setting up mate-polkit:amd64 (1.26.0-1) ...
Setting up xnview (1.3.1) ...
Processing triggers for mate-menus (1.26.0-2ubuntu2) ...
Processing triggers for mailcap (3.70+nmu1ubuntu1) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu3) ...
Processing triggers for desktop-file-utils (0.26-1ubuntu3) ...
Processing triggers for bamfdaemon (0.5.6+22.04.20220217-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for man-db (2.10.2-1) ...
Errors were encountered while processing:
 boinctasks-js_1.3.3_amd64.deb
 chrome-remote-desktop

I re ran sudo apt update and upgrade, fixed broken packages and it SEEMS to be ok. Moral of the story: Make sure you are in the right directory!

2 Likes