Is there a way to make the dock transparent?

I have the dconf-editor installed and running, but I would like the so that I could make the dock transparent. I tried Plank themes none gave me what I need. How do i add this extension. Please dumb the answer down, as I am new to all this.

You can edit plank themes to your liking whether it comes to shape, colors/gradient) and transparency.

Dash to dock is a Gnome extension for the Gnome desktop environment. It's not made for MATE.
Install Ubuntu 20.10 (the vanilla, Gnome flavour)for your Raspberry Pi if you want to try the Gnome desktop environment.

OK, but the plank settings transparent isn't look below.

Try to open MATE Tweak and select Marco (adaptive compositor) as a window manager in the «Windows» tab.
I don't know if it's available in the Pi image though. Should it not be, there won't be transparency in Plank.


OK, I had already tried those suggestions, so I guess I am stuck. Thanks anyway.

I'm advising you this theme :slight_smile: :

It's the one i'm using :

It's transparent, simple and good looking :slight_smile:

I have it installed, but I can't get transparent. I don't know what I am doing wrong. I choose it in the Plank app. Thanks.

Did you choose it in plank configuration ?


It should be transparent.

Yes I did, I tried many, none transparent.

Change it here for mac osx :slight_smile: :

That is what I did. Here is my screenshot. As you can see not transparent.

The Transparent you can see there is the theme name :slight_smile:
It doesn't mean that it will be transparent (even if with such name it's suppose to be)

So what theme is actually transparent?

Try the one i have proposed you :

Download it, unzip and put it inside this folder : (do not do it as root but as your regular user)

~/.local/share/plank/themes in order to have it like this :

~/.local/share/plank/themes/Mac Black 2.0

Next you will be able to see the new theme inside plank :

Transparency works if you have compositing enabled. Enable Marco adaptive compositor in MATE Tweak as @Utsuro suggested.
Compare default 'Transparent' theme with compositing off and on:


Is this the proper location? If yes that is where I put all my themes. Also i do have the adaptive compositor on. But I had to turn it off, then I rebooted and turned it on again. It took this time. Thanks, for the hand holding.

You're welcome. The location looks fine. If everything is correct, your installed themes shall appear in drop-down list in Plank preferences. Check /usr/share/plank/themes for reference. Folder structure shall be similar.

Yes they were before, but the composite agent didn't take. Don't know why, but working now.

@ironfoot I have run into a strange problem! If I reboot or shutdown, and then reboot Mate-Tweak doesn't remember the setting, and once again not transparent. I have to open Tweak and unselect the macro-compositer and then reselect it. Is there a fix for this?

Hi @Sparks,

I never faced such a problem. Unfortunately, I'm not using Raspberry image and cannot confirm this. You may have found a bug of some sort. Issue tracker for marco is here.