Issues with using Gdebi

I’ve noticed this several times now. Trying to manually install a deb with Gdebi has an extended delay without actually bringing up the authorization dialog. It can take multiple times before the deb will actually get authorized.

Recently while attempting to install discord, there was an error:

dpkg: error: unable to read filedescriptor flags for <package status and progress file descriptor>: Bad file descriptor

I redownloaded the file with a different browser (I use Pale Moon but I switched to Firefox to ensure this wasn’t simply a bad download.) Same result. Any ideas?

Tossing the error into a search engine shows this is something which seems to happen off and on again. Reading the comments in a Launchpad bug report I saw mention that manually installing from the terminal seemed to still work, the issue seemed to be only inthe Gdebi-gtk installer. I can confirm that, I was successful installing my debs manually from the terminal with this command:

sudo dpkg -i my-file.deb

Have changed the thread name to better reflect the issues at hand.

Hi @bornagainpenguin,

I got around the problem by installing “Software” and using that to install .deb packages, I must admit I haven’t checked out the bug list on Launchpad though!. :smiley:

The gdebi bug is known and being worked on.


Thanks, I’ll not post about it anymore then.

Holey moley! Thanks for mentioning it, BornagainPenguin
I had the exact same problem trying to install a dependency for YACReader, I even asked at their forum.
I will also not ask about it anymore now that it’s on the to-be-resolved bug list … BUT I’ll wait anxiously for it to be solved. YACReader (IMHO) is the best comics reading platform I’ve come across. I’m currently using Okular, but it doesn’t open the .zip folders properly.

it worked! sudo dpkg -i (and then I drag and dropped the file directly into the terminal window) and then sudo apt-get update – sweet laweez, lalalala! awesome!

Hello future people, (including myself)

Here is what we've found so far. Apparently this is a bug that has been ongoing, the latest of which is here I have added myself to it and you should too if this is affecting you as well. It is post #41 which provides relief. Follow the links there and get the two files needed:

  • gdebi_0.9.5.7+nmu5ubuntu2_all.deb
  • gdebi-core_0.9.5.7+nmu5ubuntu2_all.deb

Download these to your directory of choice and open a terminal there. Then in the terminal (assuming the two files are the only debs in this directory) do the command:

sudo dpkg -i *.deb

This will require you type in your password and then it will install any *.debs in that directory. So make sure that you only have those two files in this directory when you run this command. Once the files are installed you will be able to proceed as normal. Hope this helps people in the future (including myself, probably) if this comes up again.

Much thanks to everyone who solved this issue in the thread linked above.

Is this still a bug that is being worked on? Just recently upgraded to Ubuntu-Mate 21.10 in order to be ready for 22.04 LTS and any testing that will come and I am encountering this again.

Is there anything I can do to assist with reporting?

Recently gdebi has refused several times to close after installing .deb packages, and I had to kill it. I'll check if the update you describe solves this issue, too.

Maybe I'm blind, can't find the mentioned .deb files.

It appears the aforementioned changes have landed in impish-updates, and assuming that you have them enabled (check the Software Sources or your /etc/apt/sources.list file for active instances of impish-updates), you can just apply your normal updates using:

sudo apt update; sudo apt upgrade

...and all will be well.

1 Like

Thanks for the information! I'm using UM 20.04, so I'll wait until the changes show up in the Focal repo or until 22.04 LTS will be published.

If I already took my own advice and installed the files manually as described above, will i be able to automatically update to those new versions or do the ones I have now have higher version numbers causing them to be disregarded in favor of my manual installation?

As much as I'm happy that the issue has been solved for me, I'd rather be on approved system versions for something as basic as gdebi to make sure that it doesn't cause me issues down the road.


I think you've manually installed the same version of GDebi that is now in the update repos. Therefore, in my experience, going down the line these packages will not get in the way of upgrades or the like.

However, if you want to be sure, you can sudo apt reinstall gdebi to ensure that you've got the right/ most current packages installed.

1 Like