Jam HDMX wireless blutooth speaker won't play music

I have been a Zorin 6.0 LTS user and have now moved to Ubuntu Mate 16.04 as Zorin is coming to end of life. I have a Jam wireless speaker I use to listen to music on my patio. I use Clementine as my music player. In Zorin I just paired the speaker, connected and it played what the Clementine music player was playing.

The new bluetooth interface is completely different. I found the Jam speaker, paired it with the correct PIN. Then connected with audio sync. It tells me it is connected but no music plays over the speaker. If I go to Sound Preferences, hardware and test speakers the right and left speaker test come over the speaker, so it is paired and working. I know I am missing something, but what? I have tried file transfers of Clementine, and of the music folder that I am playing, but that didn’t work either.

I am guessing things have change over the years since I have used Zorin 6. I think my problem has something to do with file transfer. I could not find a tutorial for blue-tooth wireless speakers. What do I need to do to get the music to play over my Jam wireless speaker? Any help would be greatly appreciated.

Even though I had no responses I have been working on this issue. It was basically a hardware issue. The Jam speaker came up disabled under sound preferences/ hardware… Also the hardware under sound preferences had selected the wrong speaker/sound output for the Jam speaker. I set the hardware setting to off. Then removed the device from blue tooth. I then found the device again and installed and sync-ed the device. The went back into hardware and output and set the correct hardware profile to the correct hardware speaker and output connector. The audio sync then worked and my speaker now plays Clementine music or music from websites I listen to, like Streema or Spotify. Hopefully this can help someone else. The GUI and sync have changed dramatically since Zorin 6 and I was very unfamiliar with it. This is the only bluetooh device I use.

1 Like

Hi Jymm,
I had the same issue, could solve it now. Thank You!