Keep Windowed Fullscreen window below all other windows

I have a window in Windowed Fullscreen mode that I want to always keep BELOW all other windows. Currently, in this fresh install, mousing over the Windowed Fullscreen automatically raises that window to the top and hides the other windows.

My Window Preferences ->Behavior config is to select windows when I mouse over them but NOT to raise them. That window gets raised anyway.

Im running 20.04 and was able to reproduce the behaviour.

My steps were-
Have window placement ‘select windows when mouse moves over them’ and ‘unselect windows when mouse leaves them’ checked.

I left ‘raise selected windows after an interval’ unchecked.

Make firefox maximised
Have control center on top of firefox.
I can move mouse over each of the windows and they are selected but firefox remains behind.

Now make Firefox fullscreen by f11.
Alt-tab to get control centre back on top.
Moving mouse between windows brings firefox to forefront.

As a workaround in the meantime might I suggest that you do not fullscreen the app, but instead try the feature under mate tweak - windows - undecorate maximised windows?
This will save a little space but they wont be fullscreen.


Thanks for your effort! You are saying that this is a bug?

I've seen in other setups (Plasma, for example) that there was an explicit option to keep a window below others and thought there would be such a setting somewhere in Mate.

I dont know. We can wait for an admin to say if its a bug or not.

Installing gdevilspie will allow you to explicitly define a window to be below other windows. If you want something a little easier to use at the expense of using a more weighty compositor, Compiz' Window Rules plugin configurable via CCSM will allow you to use regex for defining which windows are beneath others.

That's all I can recommend as a tempfix for now. Wish you luck!

Thanks, gents. I'll workaround until a bugfix is implemented.