Keyboard doesn't work at startup

I am using a Lenovo Edge 2-1580 running Mate for a good while. Came home from work and the fan was going crazy, the laptop isn’t hot so it didn’t over heat or at least I don’t think it did. Lifted the lid and the decryption screen was up, tried typing my password and when I hit enter another dot popped up. hit backspace again another dot. I then thought hmm that’s weird tried rebooting. Grub popped up. I only have mate installed on this machine no real use for Grub. Hit enter and the timer stopped and froze. Tried rebooting again let the timer run and it booted to the decryption screen. Tried to enter the password again same issue. Rebooted again went to the grub screen and just started pressing buttons nothing until I hit “,” then something popped up. it looks like a terminal with setparams ‘Ubuntu’ at the top and a bunch of other stuff under it. Now when I hit any key something registers but most keys are “6” a few are random letters and that’s all I can do. I tried going into the Boot Sequence by hitting f12 after powering back on but no luck, I even tried f10 and f2 those are all common boot or bios buttons. I know it was a long one but can anyone help?

tl;dr Came home and laptop was on and keys wouldn’t work at all. Tried the common fixes can’t get it to work. HELP!!!

That seems like a pretty serious corruption.
Hold ESC during power on to get to the grub menu, instead of normal boot boot your last kernel in recovery mode.
If that doesn’t work try and boot the previous kernel in recovery mode.
If your keyboard works there it should be possible to restore your system.

ESC does nothing. I am thinking about letting the battery completely drain, and seeing what happens. When I let it boot up from countdown there is a quickly flashed message of “can’t reactivate aux port”

Could be hardware failure. I hope you have a backup. :x

There really was nothing important on it. It was a laptop that my mom was having issues with. Sent it to get repaired once already. I was going to use it to learn programming and what not. Any way to salvage it?

Try again to reach the BIOS using the time-honored practice of hammering the FKeys all at once like a madman until one does the trick. If it’s really a hardware failure I’m afraid you’ll have to break it for parts.

Nope didn’t work. Like I said I am going to try to run the battery out and see what happens. Thank you for trying.

Can you try plugging in a normal USB wired Keyboard and see if it picks
it up as well? Most seem to work in parallel? It might aid the rescue
if nothing else.

Cheers, Rob

external works oh yeah we got something now what lol.

I let the battery die and plugged it back in Key board works fine.

1 Like