Kodi uninstallable on 16.04 LTS

Anyone else experience this?

" The following packages have unmet dependencies:

kodi: Depends: kodi-bin (>= 2:16.0~git20160228.1453-final-0xenial) but 2:16.0~git20160228.1453-final-0xenial is to be installed"


go here and install the all.deb package using Gdebi and then run:

sudo apt-get install -f


1 Like

The APT INSTALL on the same page seems to do the trick, thanks

1 Like

Glad to hear it, I am having a problem myself with the 64 version but the 32 bit version is okay!.

Please tick best answer to mark it as solved!. :smiley:

I have the same issue followed the instructions above and is does not work. Will the Mate Welcome be repaired so that I can install KODI from Mate Welcome

Hi Alex,

there are a couple of packages missing from the Ubuntu repos at the moment, I am sure that it will be sorted out within the next few days. Please remember that UM16.04 is still a baby and is learning to walk!.

Did you try APT per @Jaime_Tayag’s suggestion?. :smiley:


do these 3 downloads in order and install with Gdebi and it should work (64 Bit version!, if you need 32 bit, search for those on same site or use the all.deb packages!):




1 Like

Wolfman, you da man! Thanks!

1 Like

Is there a version of kodi-bin for Raspberry Pi 3?

Hi @tvd0405,

does this help although I have not read through it so I am not sure if it will work on Raspi 3!:


The default installed version of Kodi 15.2 crashed on Raspberry Pi 3

Check out their forum and you might get lucky?:


I joined and created and account just for an update ---->

Great Wolfman but I was still having problems to install in x64 I did:




In that order with your instructions using Gdebi but when installing it was still asking for:

libshairplay0_0.9.0.1-2-xenial_amd64.deb and libcrossguid1_0.1-git20150807.8f399e8-xenial_amd64.deb

I Installed them from the ubuntuupdates.org website but was stuck when installing kodi_16.1-git20160425.1001-final-0xenial_all.deb ; No errors or dependencies issues using Gdebi, but same “kodi:depends (<=” when on CIi

Quickly fixed it using:

dpkg --force-all -i kodi_16.1-git20160425.1001-final-0xenial_all.deb

Everything running smooth now :slight_smile:

PS: Feel free to change the syntax of this, my english is bad


Your English is fine

Welcome to our forums :slight_smile:

1 Like

Thanks you @anon42388993 !!

I was lurking around it seems like a nice community

When trying to install Kodi I get this message. Can anyonehelp?

The following packages have unmet dependencies:
kodi : Depends: kodi-bin (>= 2:16.1~git20160425.1001-final-0xenial) but 15.2+dfsg1-3ubuntu1 is to be installed
Depends: libshairplay0 but it is not installable
Recommends: libva-intel-vaapi-driver but it is not installable or
i965-va-driver but it is not installable
E: Unable to correct problems, you have held broken packages.

I am running Ubuntu Mate 16.04 on a rpi3

Hi @skitzoontheloose,

for Raspi go here:


BTW this is on an Apple iBook G4

Hi CodeJammer007,

you can get a deb version from here (ver:17.1) which is a start!:

https://pkgs.org/download/kodi :smiley:

See also:


What update mirror are you using for Ubuntu Mate updates?, have you tried changing them because of the missing dependencies?: