Laptop brightness control shortcuts not working

Hi Team,
I am having Dell Vostro 2520 laptop. Recently, the brightness control shortcuts using Fn keys is not working. Although the volume control shortcuts are working perfectly fine. I assume this is due to some updates which I did available from the Software and Updates tool . As these brightness controls were working perfectly fine since the day I installed this distro 2 years back. I tried some of the solutions found on net like changing /etc/default/grub file with
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor". Earlier, it was "quiet splash nouveau.modeset=0" but it set the screen to full brightness which is not acceptable.
Note that, I do not have a Nvidia driver in my laptop.
Kindly advise me on this fix.


@olek can you help me with this issue

Hi there :slight_smile:
Are you able to change brightness with this setting ?

Inside control center > Power Management

If you are able, maybe its only a action key issue. Let us know :slight_smile:

No luck here @olek. Already explored that option.

Hmmm ... strange ...
Did you done sudo update-grub after editing /etc/default/grub file with GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor" ?

We will fight it :slight_smile:

Yes, I did it. Even tried with =native value.

Can you try to test your keyboard with xinput ?

Run in a terminal :
xinput list

⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ ETPS/2 Elantech Touchpad                	id=11	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ AT Translated Set 2 keyboard            	id=10	[slave  keyboard (3)]

Identify your keyboard ID (mine here is 10) :

xinput test 10

and send the brightness commands from the keyboard. My side i'm not receiving the commands inside xinput. The HW is understanding it and changing the backlight. Let's see your side :slight_smile:

one more thing you can do is to try installing some drivers. go to Control Center and locate Additional drivers :

Next try to install some maybe missing drivers. Good luck :slight_smile:

EDIT : I found that and I'm thinking more about some drivers ... Can you try this ?

Hi @olek, I will try these tomorrow. Have couple of queries:
Do I need to install xinput tool ?
What do you mean by send brightness command from the keyboard ?
The Additional drivers tab does not show any drivers.
Will also look into Dell website for display drivers

xinput is already installed on your machine - nothing to be installed :slight_smile:

send brightness commands - try to change brightness with the brightness keys on your keyboard

Also, please try to go to BIOS and set up the "Function Key behavior" inside "Advanced" tab to "Multimedia" or toggle it.

Good luck :slight_smile:

@olek, I tried the above 2 suggestions: xinput and changing the bios. Unfortunately both the things didn't work. Infact, after changing Fn to multimedia, I was not even able to changing the volumes. Only mut volume was working. So reverted it back.

Maybe update the BIOS will help

Hi probably not the answer but on my Precision Dell Laptop 20.04.1 I have to hold down the Fn key and press the corresponding F key with blue icons. Not sure how it is on your laptop. But may not as on my laptop I cannot change volume without holding the Fn key. Just a guess.

1 Like

Volume shortcuts are working perfectly fine. Only issue is with brightness shortcuts

Oh. I do not won't to go that far. Let me try by updating everything available under the Updates tool

Hi @olek, updating the necessary files from Updates tool did not have any effect.
However, I was able to set the brightness to some value 978 using the below command
echo 978 > /sys/class/backlight/intel_backlight/brightness. I can change the brightness by modifying the number.
But, this is a fixed value, so the brightness controls are still not working.

Can anyone suggest a fix for this.