Large Icon In System Tray - Synology Cloud Station

software

#1

Hi guys,

I used Synology Cloudstation to sync my files. But when I open the application, the system tray icon is massive compared to the others. It just look ridiculous. Is there anyway I can fix the system tray icon?

I’ve tried changing my icon theme, then logging out and in, but it doesn’t help, so I don’t think it’s my icon theme. Here’s a screenshot of what it looks like:

TIA


Synology DiskStation Large System Tray Icons
#2

kev,

Looks like you’re using the Adapta theme. Have you also tried one of the other built-in themes, and/or built-in icon sets?

What sync program are you using? Don’t see a synology-specific in the repo. If you’re running a program that you downloaded, you can navigate into that folder and usually find the icon image and resize or replace it.

GM


#3

Hi GM,

Thanks for coming back to me. You’re correct, I am using the Adapta theme. I tried changing both the GTK theme and the icon theme, but it’s still the same. I changed everything over to the “Ambient MATE” theme.

The Sync program is Synology CloudStation Drive. It’s not in the repos (I don’t think), it’s installed via a DEB that’s downloaded from the Synology website (link below), or the Synology device.

https://global.download.synology.com/download/Tools/CloudStationDrive/4.2.7-4415/Ubuntu/Installer/x86_64/synology-cloud-station-drive-4415.x86_64.deb

I had a look around /opt/Synology/Cloudstation, but I couldn’t find any system tray icons. The only icon I could see was the PNG for the application icon. No system tray status icons.


#4

Ok. More weirdness.

So if I run the application from /usr/share/applications via Caja with sudo, the icon seems to be scaled correctly. However, if I run it in normal user mode, from the Brisk menu, i still ave scaling issues.


#5

That’s the .desktop file. You can right click on it, and open with Pluma to navigate through the settings.

Check in your home folder first, under ~.config or .Cloudstation (which won’t run into permissions issues). There should be a similar instance that you can use.

Either way, you can add a custom application launcher to your main panel (right click & add) and link it to that file. If you need an icon, you can also navigate and use anything you’d like. The PNG should be the same for both app and tray.

When you use non-repo programs, expect the possibility of some behavioral nuances.

GM


#6

Clementine does the same thing.


#7

We’re making progress (thanks again for the continued help).

So the tray icons are in ~/.CloudStation/CloudStation.app/images/tray. They’re all PNG - would have thought they would be SVG. Anyway…

I’ve resized one of them from 72px to 28px. Now, when I load the application, I get a “link broken” type image instead of the resized logo. Am I missing something here? Broken icon is highlighted by the red square below:


#8

Done some experimenting. It seems that if the image is less than 32px, it errors out. So I worked around it by adding transparent padding to the system tray icon. Not the most elegant solution, but it certainly works.

Thanks again for the help, GM. It really is appreciated!


#9

I’ve made a selection of icons that should work with different themes. I put together a quick post on how to fix the issues. Link below for anyone else having the same issue:

Icon themes:


#10

Sure, just a resizing of the icon. It’s not mono-chromatic, but it works nicely in your panel.

Congrats, nice blog post and tutorial. That’s a nice icon pack that you’ve provided.

I think those would fit nicely within the default UM icon set. Maybe you can try to contact headquarters with your creation, or even link your tutorial from within the forum’s tutorial page.

Nice work!

GM


#11

Thanks GM, I’ll look in to doing that.

I just added a thanks to you to the post, can’t believe I forgot that the first time around!


#12

A better way is to have a chat with the main devs of that app and make a request to add your icons in the app/project. Because the problem is at their end not Ubuntu Mate’s.