Lenovo B570 will not shutdown

I have 18.04.3 installed on a Lenovo B570. System starts up fine, will restart, but will not shutdown. I reviewed the syslog no errors or warning are shown. Once the shutdown is clicked, the screen goes to the splash screen and two dots turn white and it hangs up.
Lenovo B570
8GB DDR3L 1600
240 GB Crucial SSD
Pentium B950 (2.1ghz Dual Core)
any help would greatly be appreciated.
I have reinstalled twice, tried 18.04, 19.04, Linux Mint all do the same thing. Win10 shutdown correctly.

Welcome to the forums. I have not experienced this issue in 18.04.3 however I have seen this issue referenced to a possible issue with the hardware and ACPI.

Can you open a terminal and run this command shutdown -h now does that shutdown the system? Does it show any errors in the terminal?

You can take a look at this post which is for version 16.04 but still applies to some system today:

The most common fix seems to be:

Make a backup of /etc/default/grub then

Open /etc/default/grub using sudo with your editor of choice.

Edit GRUB_CMDLINE_LINUX_DEFAULT="quite splash" so that it says

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"

Save and exit your editor.

sudo update-grub

Reboot and then see if you can shutdown correctly.

There are also some options options mentioned in the thread linked above, if this does not work.

Good luck.


Thanks for the reply. The grub file is read-only and will not let me do any editing to it.

You will need to use sudo

Thanks Frank, no joy though. I tried all of the solutions, still locks up. I appreciate you trying though.

well, i have tried several non debian/ubuntu based distros and also POP! OS. Same out come. I really like the Mate Desktop, so When I am done with each session I guess I will just power off with the power button. According to the syslogs everything is unmounted or shutdown, so hopefully it wont hurt anything.