Libre Office has stolen the zip extension

I'm trying to reassign the Zip archive filetype back to engrampa archive manager from libre office.

This is in 23.10, soon to be upgraded to 24.04 when it comes out.

I have the archive manager as a choice, if I right click, but a double click still launches the file in Libre Office, which fails, since it's not a libre office document.

When I right click, select properties, then the 'Open With' tab, I get two radio buttons:

  • Engrampa
  • LibreOffice Calc (selected)

When I try to select Engrampa, the radio button won't select. If I try to 'remove' the LibreOffice Calc using the remove button, that silently doesn't work.

I'm not sure what underlying file this is trying to edit, but perhaps it doesn't have the right permissions. Or something else.

Has anybody got a clue?


1 Like
$ grep zip /usr/share/applications/defaults.list

if you add engrampa.desktop at the end ...
zip files should be opened with engrampa

I don't have 23.10 but I checked on my 22.04

1 Like

Running Ubuntu 22.04,
LibreWolf is an appimage in ~/bin/librewolf

I have been trying to make LibreWolf my default browser, without much luck.
I did use 'about:config' in LibreWolf, and changed the '' to true, but then closed and relaunched the browser, clicking yes on the requester ro make it the default.

It worked for a short time, then not at all.

Is there any entry I can make in the '/usr/share/applications/defaults.list' that will make LibreWolf my default browser?


First, you need to register wolf in /usr/share/applications/wolf.desktop

[Desktop Entry]
Exec=/usr/local/bin/LibreWolf.x86_64.AppImage %F

then edit ~/.config/mimeapps.list and add an entry for Wolf (like firefox).

[Added Associations]

Now, Control Panel > Preferred Apps ... Web Browser has one more entry, wolf. Select it, then close.

In terminal, type, right click, open link it will use wolf to open that link instead of Firefox.

You will notice in ~/.config/mimetypes.list firefox was replaced by wolf

[Default Applications]

Hope this helps
(tested on um22.04)

ADMIN: this should be a separate post how to register an AppImage and make it default app.

1 Like

This did not work for me. I edited the defaults.list as root, tried again, logged out and in again, tried again, and rebooted (just to be sure) and still zip files launch in libre-office. I checked the file I am using for testing and it's indeed application/zip. Thanks for the suggestion, however.

I'll be going to 24.04 when it's available but I don't expect a change.

Right click on a zip file. Select:

Open With Other Application...

In the next window make sure the check box is checked, find Engrampa and select it.

That's the method I use when changing default applications. I didn't read that you had tried this.

1 Like

my example was for another browser, not zip files. See @mdd12 's reply.

@mdd12 My initial posting discusses your suggestion.

So i'm not able to make that selection. Perhaps something is read only that should be read/write but I don't know what.

@pavlos_kairis Thanks. Your initial response was to me, in which you suggested that I edit defaults.list.

You also answered lar3ry regarding LibreWolf, but that's not what I tried.

Thank you.

Right click but don't select properties. Instead select Open With Other Application...

You will get a list: