LightDM - blank, white background instead of my chosen picture

My LightDM background got blank all of a sudden, just white and plain. I can still log in as the login window appears as always. However, I would like to be greeted by a pretty picture. Any idea how to fix that?

Sounds like Lightdm has lost its connection to the standard background. This has happened to me before.

Okay do the following:

Open System/Administration/LightDM GTK+Greeter Settings. See below:

You will see, in the screen-shot, there is a long button with "untitled_by_Troy_Jarrell.jpg" written on it. That is my current login screen background. You need to press this button and navigate to a picture you want to use for the background.

For your information, the standard mate backgrounds are in /usr/share/backgrounds. But, you can navigate to anywhere you have pictures stored. Just make sure that, having once chosen a picture in a given location, you do not subsequently move that picture because, if you do, LightDM will lose the connection and you will have to reassign it.

1 Like

Hi @stevecook172001,

Thanks for your help.

I tried that but I gave it another try. I changed the background again but still a blank background greeting me :unamused:

What is weird though, I can see the background I chose for LightDM right after I entered my login credentials:

Here are my LightDM settings

I tried with "Use user wallpaper if available" ticked and unticked, no difference.

I wonder what's wrong. This issue appeared when I updated nvidia-settings app. I don't know if that has something to do with but Nvidia is known to mess up things :grinning: and I still remember that I had to use time-shift to revert back an Nvidia update that lowered my max resolution horribly low. After a 2 months I tried the update again, it worked out that time.

BTW: Is there a file where the LightDM settings are stored? Maybe by taking a look we can find the bug.


Thank you, I checked my configuration file and didn’t find anything out of the ordinary.

background = /usr/share/backgrounds/ubuntu-mate-common/Ubuntu-Mate-Warm-lightdm.jpg
theme-name = Ambiance-Flat-Graphite-Pro
icon-theme-name = Radiant-MATE
font-name = Ubuntu 11
xft-antialias = true
xft-dpi = 96
xft-hintstyle = hintslight
xft-rgba = rgb
indicators = ~host;~spacer;~clock;~spacer;~session;~a11y;~language;~power
clock-format = %a %d %b, %H:%M
-keyboard =
-reader =
position = 50%,center 50%,center
default-user-image = /home/liam/Pictures/System Pictures/Profile.jpg
screensaver-timeout = 60
a11y-states = contrast;font;keyboard;reader
active-monitor = 0

Does anyone know how to reset all LightDM values to default?`

I suppose one thing I might try, if it was me, would be to un-install and purge and then re-install lightdm. Which would be:

sudo apt-get remove lightdm

sudo apt-get purge lightdm

sudo apt-get autoremove

sudo apt get update

sudo apt-get install lightdm

Make sure you do all that at once, though, in the same desktop session. Otherwise you might find you no longer had lightdm to log in with.

Deleting the file then redoing the lightDM in control panel should regenerate a new lightdm-gtk-greeter.conf

Thanks for your input. Unfortunately, things gone worse. I did a “combination” of the suggestions of @antechdesigns and @stevecook17200 with the result that the lightDM greeter does not appear at all. I need to enter startx to login after having logged in terminal. Guess, I messed things up badly.

Maybe the contents of these files help:

    [Desktop Entry]
    (omitted other languages and comment)

[Desktop Entry]
Name=LightDM GTK+ Greeter
Comment=This runs the GTK+ greeter, it should only be run from LightDM

[Desktop Entry]
Name=LightDM GTK+ Greeter
Comment=This runs the GTK+ greeter, it should only be run from LightDM

background = /usr/share/backgrounds/ubuntu-mate-common/Ubuntu-Mate-Radioactive-lightdm.jpg
default-user-image = /home/liam/Pictures/System Pictures/Profile.jpg

# User accounts configuration
# NOTE: If you have AccountsService installed on your system, then LightDM will
# use this instead and these settings will be ignored
# minimum-uid = Minimum UID required to be shown in greeter
# hidden-users = Users that are not shown to the user
# hidden-shells = Shells that indicate a user cannot login
hidden-users=nobody nobody4 noaccess
hidden-shells=/bin/false /usr/sbin/nologin

oh dear! Do you still have a lightdm folder in your etc?

Yes, the folder is back after reinstallation of lightdm.

and does it contain all the files like in the pic above?

lightdm.conf.d folder is empty
lightdm-gtk-greeter.conf.d inside folder should have 99_ubuntu-mate.conf

and do all the .conf have text in them?

Thats how mine is set up, is yours the same?

EDIT Going back over this thread i notice you have use user wallpaper if available ticked, maybe thats the original problem??

Thanks for standing by, it looks like I got files and a folder missing :worried:

Create the missing folder lightdm-gtk-greeter.conf.d then inside that folder create the file and name it 99_ubuntu-mate.conf then paste this text into it. You might have to right click the lightdm folder and open as admin to make those files.

# background = Background file to use, either an image path or a color (e.g. #772953)
# theme-name = GTK+ theme to use
# icon-theme-name = Icon theme to use
# font-name = Font to use
# xft-antialias = Whether to antialias Xft fonts (true or false)
# xft-dpi = Resolution for Xft in dots per inch (e.g. 96)
# xft-hintstyle = What degree of hinting to use (none, slight, medium, or hintfull)
# xft-rgba = Type of subpixel antialiasing (none, rgb, bgr, vrgb or vbgr)
# indicators = semi-colon ";" separated list of allowed indicator modules. Built-in indicators include "~a11y", "~language", "~session", "~power". Unity indicators can be represented by short name (e.g. "sound", "power"), service file name, or absolute path
# keyboard = command to launch on-screen keyboard
# position = main window position: x y
# default-user-image = Image used as default user icon, path or #icon-name
# screensaver-timeout = Timeout (in seconds) until the screen blanks when the greeter is called as lockscreen
font-name=Ubuntu 11
position = 50%,center 50%,center
default-user-image = #avatar-default
screensaver-timeout = 60
user-background = false
clock-format = %a %d %b, %H:%M

Update: I installed SLIM as display manager and it’s working. I know it’s not a perfect solution but I get graphical login. I try to fix lightdm later.

BTW: I received this error message when I tried to start lightdm manually: “unable to connect to upstart” or similar.

Thanks to all who tried to help.