Linux Kernel 5.3 (UM 19.10) cannot support 2080Ti

I've got a BIOS code AF when i try to enter the install GUI.

Welcome! What's your motherboard and CPU? Have you tried checking for updates for the BIOS?

ASUS x299 WS SAGE/ intel i9 7920x. 19.04 is well. I found all ubuntu 19.10 release distro cannot enter the install GUI. I've installed the latest BIOS.

I had a quick look on the web and couldn't find anything specific to your hardware. :confused:

Considering differences between 19.04 and 19.10, some possible reasons could be:

  • New Linux kernel
    • 19.04 = 5.0.0-25
    • 19.10 = 5.3.0-18
  • Proprietary graphics used by default - in the ISO menu, have you tried the (safe graphics) option?

To boot with more detail, press F6 then ESC at the boot menu, delete quiet splash then press ENTER. (It might be e and F10 if it's showing a GRUB2 menu.)


You could also try adding nomodeset in place of quiet splash, to see if this makes any difference.

Also check the BIOS is booting the install medium in UEFI mode. The boot menu might not look the same as above in this mode :point_up_2:

I found all ubuntu 19.10 release distro cannot enter the install GUI.

Are you able to boot using the "Try Ubuntu MATE without installing" option?

:camera: Please upload a screenshot of the AF error, as this may help visually.

Yes, It's the kernel. I've ever do a sudo update-manager -d to upgrade from 19.04 to 19.10, and it can not boot with 5.3 kernel, but be well with 5.0 kernel.
I'll try nomodeset later.

I tried adding nomodeset, the same AF code of my BIOS .
AF code is showing on the debug light of my motherboard.

Do you have any overclocking configured? It might be worth clearing/resetting the CMOS to see if factory defaults allow the newer kernel to boot.

According to the manual, we can conclude something is not right with the hand off between the BIOS and 5.3 kernel:

AF Exit Boot Services event


If you haven't already, you could try removing all components and plugging them in one at a time (RAM, GPU assuming CPU has internal graphics, storage) in case one of them is triggering the system lock up.

I also have an issue with video output on VGA connector with 5.3 kernel, witch will trash an error on boot, and stop loading Mate. Previous kernels work OK... Video is Intel onboard

So we both probably have to wait for next kernel release ...

No overclocking, other i7 6700k overclocked PC can be normally boot.

It's solved after I update the ASUS latest BIOS 2002. Thanks