Linux won't boot after dual-boot install on G5

installation

#1

I have a G5 2.0 with 10.5.8. I resized my HFS partition and then booted the live CD of 16.04.1 for an install. Everything seemed to go fine and I selected the option to install alongside OS X. After the reboot, I got what I assume is the yaboot menu with linux, os x, and CD. To be clear, there is no “boot” like I get with the live DVD that will allow me to enter boot parameters. If I select any of those options, I get a gray screen and the fan runs faster and faster until I shut it off. I am using a non-apple monitor connected via DVI. If I boot holding the Option/Alt and select OS X, it boots fine. I tried reinstalling twice. No errors, but same result. I have attempted to read every similar post and the FAQ. I am currently trying to boot with the live DVD so I can edit yaboot.conf and edit the boot parameters. This is not life and death, but I would like to get it working. Thanks for any assistance.


#2

As I have read more, I am not sure that yaboot is booting. I don't get yaboot verbiage and boot prompt like I do with the live DVD. I booted to the live DVD and ran Gparted and here is what I get:


What next?


#3

It’s easy to make them both work together with newer mac osx, but the older mac osx fights for keeps! Installing a bootloader will allow you to choose, the way you can at start up on newer macs. I hate this on my older i386 macbook. I couldn’t think of any reason to keep my old osx, so just wiped it for Ubuntu MATE only. Play on Linux takes care of anything I have to have from the old system, but it has to be the PC version.

ReFIND is downloadable, and comes with easy to follow instructions on the owner’s page. He wants a small donation for his trouble, like all open source people want :slight_smile:


#4

Thanks Jason. I think your idea is my next step, but I am a hard head so I am trying to make it work. From my Gparted above, I noted that each time I reinstalled, it created another bootstrap partition. That is the three HFS partitions. The yaboot.conf in those partitions, was not correct and when I went to open firmware and tried to boot, nothing. So now, I deleted the three HFS, the ext4, and the linux-swap, and I am moving my HFS+ partition to the right to open up 1KB so I can create the bootstrap partition there. I doubt that will work, but my next step will be to manually create a yaboot.conf with correct entries.


#5

I cleaned up my partitions and reinstalled:


The three files are in the bootstrap partition yaboot, yaboot.conf, and ofboot.b, but it does not boot to yaboot. If I boot to openfirmware and then the bootstrap partition, it boots yaboot, with no options other than "boot:", but using either Linux or old, it pukes with an error. Here is my yaboot.config:

yaboot.conf generated by the Ubuntu installer

run: "man yaboot.conf" for details. Do not make changes until you have!!

see also: /usr/share/doc/yaboot/examples for example configurations.

For a dual-boot menu, add one or more of:

bsd=/dev/hdaX, macos=/dev/hdaY, macosx=/dev/hdaZ

boot="/dev/disk/by-id/ata-Hitachi_HDT725032VLA380_VFJ201R80PH9XX-part6"
device=/[email protected],f2000000/[email protected]/[email protected]/@ffffffffffffffff/@0
partition=7
root="UUID=0aa37dd7-9be9-48a6-88a1-f2de012bb92b"
timeout=100
install=/usr/lib/yaboot/yaboot
magicboot=/usr/lib/yaboot/ofboot
enablecdboot
macosx="/dev/disk/by-id/ata-Hitachi_HDT725032VLA380_VFJ201R80PH9XX-part3"

image=/boot/vmlinux
label=Linux
read-only
initrd=/boot/initrd.img
append="quiet splash"

image=/boot/vmlinux.old
label=old
read-only
initrd=/boot/initrd.img.old
append="quiet splash"

I am about out of ideas. I did check out refind, but it is not for ppc, intel only. I did try booting via the graphical menu and selecting the linux partition, but it took me to the Ubuntu Stage 1 text menu and none of those options would work. Also, I did try resetting the NVRAM, some time ago. I would really appreciate one of the knowledgeable folks helping me to get this going. Thanks.


#6

Good luck, Ling - it looks daunting mid-install, but it’s clearly explained by the ReFIND notes. I’m thinking of installing Ubuntu MATE over a family member’s G5 Mac mini

Jason


#7

Looking at this rEFInd page, it says: Earlier Macs with PowerPC CPUs use OpenFirmware, and rEFInd can’t be used with them. Am I missing something?


#8

http://www.rodsbooks.com/refind/
The rEFInd Boot Manager - Roderick W. Smithhttp://www.rodsbooks.com/refind/
Introduction. This page describes rEFInd, my fork of the rEFIt boot manager for computers based on the Extensible Firmware Interface (EFI) and Unified EFI (UEFI).
www.rodsbooks.com


#9

http://www.rodsbooks.com/refind/

perhaps it can’t be done? You’re fjording new territory, Ling.


#10

After many hours and many installs, I seem to be back where I started. My partitions are now in order sda2 bootstrap, sda3 OS X, sda4 /, sda5, /home, sda6 swap. I have manually edited my yaboot.conf. When I boot, I get an Ubuntu Stage 1 boot with options for linux, macosx, and cdrom. If I select linux or macosx, I get a white screen and eventually my fans spins up to high until I turn it off. If I try to boot via open firmware, it gives me an invalid device. I used ofpath to get the device path. Help! I am running out of ideas as to what to try.


#11

Well, you could remove the mac osx drive, and use a second “clean” hard drive for your Ubuntu install. Run one of the drives from an external usb drive by holding down the option key upon reboot. Hardly an ideal solution though. Why are you so reluctant to let the mac os go?


#12

True and that may be an option before I give up completely. I spent quite a bit of time get os x installed, updated, etc. and at this point, I am not sure that Mate will work on the G5 regardless. If the dual boot doesn’t work, I may try another drive. I have my OS X drive backed up via Time Machine.


#13

I have tried Lubuntu and got the same results as Mate, a broken yaboot and a linux partition that won’t boot. I tried Yellow Dog 6.2, which appears to be two years old and it gives me a working yaboot. It tries to boot linux, but hangs. I have always been one to play with old toys. The G5 is a pretty capable machine and it is disappointing that folks aren’t chiming in with some help, but maybe I am a dope and everyone else got it working right away.


#14

Ling, did you have any success with the multiple drives solution? I hear you about the G5 system: solid hardware, but no one supporting it any longer.


#15

Actually, I have not tried it yet. Since my last attempt:

  1. I replaced my PRAM battery. My clock/calendar would not hold the time, so i thought that my be part of my problem with yaboot/boot. It has the correct time/date now and maintains it.
  2. I added the Apple Bluetooth module.
  3. I upgraded my RAM from 2GB to 8GB

Now with all of that done… I can no longer even run the live CD/DVD, any of them. I can still go to OF either using opt-cmd-o-f or using the yaboot menu o option and then boot OS X with:

boot sd1:3,\:tbxi

It boots and runs fine. All of the new hardware is recognized and works fine under OS X. Whether using Lubuntu or Mate, it hangs at a line saying it is opening a display. Previously, Yellowdog worked well and now it won’t boot, nor will Debian or Freebsd. Good old MorphOS still boots and runs great. I googled around today and didn’t find anything. I am about ready to give up and just run OS X and maybe play with MorphOS.

So, there is no sense installing another drive if I can boot/run the live CD/DVD.


#16

You are persistent, Ling! When it comes time to update my G5, it’ll be a straight Ubuntu Mate 16.04.* PPC install, with no attempt to keep the mac os environment. It’s still running a family member’s legacy business/tax system.


#17

If I was confident I could get it working, I might do the same. At this point, based on the lack of community support, I will probably go with Lubuntu or if possible Debian and run Gnome. Mate has already announced EOL for PPC support and the community seems to be almost gone, so I don’t see any value in learning a new desktop. I still plan to see if I can get it going. Kind of a challenge now and I have already learned a few things. If I get it working and it is useful, I will probably blow away the OS X partition or if I find a good drive in the garage, I may give that a shot. When the latest High Sierra update hosed my MBP the other day, I was able to get by with this one for a few hours.


#18

After having migrated directly from Snow Leopard to El Capitan, it was night and day. In retrospect, Snow Leopard was a good starting point. We kept an i386 macbook going for ages, but finally packed it in, even though I volunteered to switch out the drive for an SSD.

I’m surprised to hear you’ve had trouble with High Sierra - I understood it’s the cat’s meow, once you get past the radical new Apple file formatting. I haven’t migrated to HS yet because it insists on apps with entirely 64 bit software, and I am using some legacy Adobe/Autodesk software I am unwilling to give up.

A thought – HOW are you creating the install media? Are you using the disk utility to convert the .iso into a .cdr file, then burning it onto a DVD? Could you use a new(er) mac to do it? I hear you saying multiple versions of linux won’t work/install, maybe it’s not linux…? Not trying to start a fight here, just thinking out loud.


#19

Leopard is the newest version of OS X that the G5 Powermac (PPC) will run. I am essentially doing what you suggest. I also have a MacBook Pro w/ Touchbar running High Sierra.


#20

The fun continues… I found that one of my memory sticks had a bad trace. I replaced that pair with one of my previous pairs and now 7GB is working well while I await replacement memory. Every version of live Linux CD/DVD boots fine. In trying to install Debian, I hosed my partitions to the point that GParted couldn’t fix it. I bought a copy of Leopard off eBay. I was able to rebuild the drive and get OS X back (in a single partition) working well. In the process, I tried to move the drive to the A slot and found it was not recognized. I also bought a refurbished 1TB drive and it also wouldn’t work with linux when in the A slot. Seems to be a bad cable or maybe the connections on the MB are bad. I will try to clean and replug tomorrow. I put the new drive in the B slot and installed Lubuntu. It seemed to be OK, but won’t boot. No white screens anymore, just not finding either yaboot, linux, the partition or something. I’ve tried many different open firmware boot commands, but end up with a folder/question mark. I’ve also fooled around with the yaboot.conf, etc., but still no joy. I am getting some screws/feet for the second drive and another SATA cable, so I am not giving up yet. I think it may work when the linux install is on a drive that is in the A slot.