Live session of 20.04 can't mount an ntfs partition anymore

"Disks" tells me the kind of information that tells me it needs a chkdsk, but testdisk, something I used often to save my data when it looked grim, tells me the partition, which takes the whole internal drive, but is under an extended partition for some reason (I wouldn't have done this, I left it as ntfs even if it is a drive I only got for data about 5 years ago).

The computer's BIOS/UEFI sees the drive, so it doesn't look to me like it's broken. I've been using live sessions for extended periods of time and I think my usb 3.0 extension (only have 2 in the back of the desktop, so I bought an additional seperate power source 4 port extension, so I have 5 in total that are 3.0/3.1). But when testdisk tells me something...I believe it. I really can't lose what's on there, at least 3/4 of it, I burned some of that drive's content to a BD-R 100gb but back then that thing didn't contain my "notes" files, where all my logins and everything are. I thankfully had made a copy of that file on a usb drive on dec 30th, so thankfully all of my pw's are up to I only have to worry about whether the live session, which doesn't boot correctly (I checked the usb drive on my s/o's win10 laptop so I could verify its integrity and it is fine), but a live session eventually always has trouble, and this one I had running since late november until yesterday...I might be pushing it...I know, I should just install the damn thing.

Sometimes the usb 256gb stick boots so badly it doesn't see the network adapters and incorrectly detects my sound adapters and doesn't give me permissions to change my time zone or access some other drive/partition's contents. Weird, 18.04.5 didn't do that, but then again 20.04 was a lot more stable on a live session since I started using it in august.

I have Hiren's Boot 15.2 so I will be looking to do a chkdsk and everything else to clean up the ntfs drive....if it sees it, the testdisk telling me "D" for the partitions..well, there's really only one but like I said it sees 2 because there's an extended partition of 1tb under the main 1tb partition for some reason.

Now is it possible it is only an issue with the usb ports extension (I tried 3 different ports out of 4 and it doesn't change anything, live sessions start up fine once out of 4).

This isn't a particularly old desktop, since I built it to last, amd3+ FX-9350 4.4ghz octocore, 16gb 2133mhz Corsair ram....the motherboard might be a bit overwhelmed though, with the large cooling tower and everything that's added up to it, every diagnostics I ran tells me all is running smooth though. Just can't mount a disk that suddenly refuses to when I start up a live session that always did, and I decided to look at the boot sequence by pressing escape and I see how it has a lot of issues with sdb5 (it really should be sdb1 like I said, don't know why it sees it that way but that never mattered before). Stuff I've seen before with drives that needed a windows chkdsk, nothing ntfs utils for linux will fix.

Is this something that could be fixed easily if I just installed ubuntu mate 20.04 to an internal drive finally or I should expect the same result? I'll keep you updated/edit my post after I boot with Hiren's Boot and look if I can fix it...if it doesn't see it, then testdisk is right, but i can still save the data since obviously nothing was written there since I can't access it, testdisk sees the files just fine and I could copy them to some other drive if I wanted, I don't know if I could just resuscitate it by changing its status in testdisk, I did this before, but I never had a drive act this way, usually when something is dead on it like the power, the computer itself doesn't see it.

I know I can fetch out the boot sequence for you guys to check it out, but I'm pretty busy with other things right now, but if it would help to show you what's suddenly happening when I boot from the usb stick to a live session with this sdb5 1tb partition/drive, what I've seen in the boot sequence, please go ahead. I'll check this thread later tonight. I'm frustrated enough right now that I'll just be watching TV on vlc through the desktop, spent the whole morning trying to figure what was wrong all of a sudden.

Hopefully the whole world hasn't been put on a curfew around you where you are...


Please keep your post titles brief and to the point. I had to shorten your title considerably.

Good luck gaschief.

Do you have ntfs-3g installed? (sudo apt install ntfs-3g)

Yes, but from experience and looking around, this won't help like an actual windows chkdsk, unfortunately the actual grub menu for my installed OS's is for Linux Mint 17.3, which I kept there because I wanted to move what was there (documents, downloads etc.) to another drive while I was using 18.04.5 in live session. It sucks that I used OS-Uninstaller to remove win7 x64, it kind of became useless by january last year, because I could just boot in there and get a clear idea quickly.

I burned Hiren's Boot 15.2, not sure Boot Repair OS (which is great, it's just Lubuntu coming up with a lot of preinstalled maintenance programs) has what it needs.

From experience messing with ntfs-3g doesn't do any good. I can't move the drive into my gf's desktop, it's a crappy tiny box pre-made HP desktop from 2014 or so, so low profile that a low profile asus video adapter I bought to make it better had me needing to break the metal top of the box with pliers to get the pci-e video adapter in. And it has 2 hard drives in there working together in some RAID mode where if one hard drive fails, she wouldn't even notice. No place to add another HDD, the only other sata entry is covered for the DVD-RW in there, and like all branded desktops, there's no place to add what they don't want you to add and I can't remove one of the drives since they're on a RAID mode and for all my knowledge I never messed around with RAID. Especially because I've been dual booting for a decade+, but not anymore, I won't install win10, so that situations like this don't arise anymore (have all my internal drives be ext4 for instance).

ntfsfix and such cannot help with a drive that needs a thorough chkdsk, fsck cannot help either from experience and from what I've read over the years, seems much riskier than using testdisk, but I'll save that until I boot with Hiren's Boot and use the live winxp in there just to use those windows software to do a proper chkdsk in there. Thanks for mentioning it though, I know it can help for things like superblocks and such, things I never had happen to me, but that I know of.

I was able to move most data from the "deleted" partition while still under this very same live session (that started fine), when the 4 dots next to the upper right notification zone/clock/power options, I know the live session isn't messed up, it doesn't boot like it should most of the time like I said; with Testdisk to a HDD on my SATA III hot swap dock, thankfully I have a few mechanical drives that are brand new. Some errors but mostly flawless.

Disks tells me it has 96 bad when I boot with Hiren's Boot, I'll see what I see with the windows utilities that come with the mini winxp it has in there, first, to see if it gets to see the drive, Ubuntu Mate 20.04 does, but like I said refuses to mount it for "Unknown error", Testdisk sees a deleted partition, but you can still save the files from there to another drive so long as they aren't part of the broken sectors or that no modification have happened to the partition at all...well obviously it hasn't.

I'll tell you guys what happens, if a chkdsk changed the outcome of a live session boot, if it's not as buggy for instance, one good boot out of 5 and the stick is said to be clean by win10 on my girlfriend's laptop.

I'll make sure that if I can move everything that's on there to turn the drive to an ext4 partition entirely. Situations like this make me require some form of a windows because of the very poor utilities regarding ntfs in linux, I imagine they worked better a long time ago when files were smaller and drives were smaller too, but ntfs-3g has never fixed what chkdsk fixed, and I really don't feel like having to get win10 to be shoved on a partition when I would barely use it. I can emulate all the games just fine on an installed ubuntu/debian or fedora type linuxes through CrossOver or Wine, well I could with 18.04.5, I have to commit to install 20.04 to an internal drive asap and not rely on something that promises to crash some time, a live session, stretching them over months isn't a good idea I found out. :unamused: