Login and password will not change

I was used to simply booting to ubuntu mate and automatically going to the desktop. Since upgrading to 20.10 I cannot do that. I get a login screen with a password that I have to enter to get to the desktop. I have gone to users and groups and indicated that a password is not needed, but no change. After rebooting I still get the login screen where I must enter a password. How do I get back to what I am used to?

go to users/groups and enable auto login.

Please see - Auto login to my account

where you can edit the etc/lightdm/lightdm.conf file to get an auto login.

The file should contain these lines:

[Seat:*]
autologin-guest=false
autologin-user=rick
autologin-user-timeout=0

in order for 'rick' to automatically log in.

2 Likes

I have tried to edit that file, but I don't know what program to use or how to edit and save. When I tried to save, I got an error that I could not save it.

That's exactly what my .conf file looks like.

I have done this and nothing changed.

So, you are running lightdm, the conf file is set to autologin, you logout/login and are prompted for user/password? I'll spin up a VM and try ...

Solution from @mdooley works perfectly, I tested that earlier when tried to configure new greeter.

You are using 20.10 correct?

So you've set Control Center>Users and Groups to "Don't ask for password on login", correct?
Do you have an /etc/lightdm/lightdm.conf file? Did that file exist or did you create it?
Do you have this file in /etc/lightdm/lightdm.conf.d/90-arctica-greeter.conf?

If you have the 90-arctica-greeter.conf file please add the following line and reboot and see if you are logged in automatically.

autologin-user=yourusername

1 Like

I tried to reproduce as well but could not. Autologin works fine with lightdm.conf set as mentioned by @mdooley.

@Rick_Rufenacht, you seem to have upgraded from 20.04 instead of a clean install. Is that so? You had issue with shutdown indicators (which btw you solved by yourself :+1:). Could it be an incomplete/improper upgrade?

Can you please provide output of following commands? Menu->System Tools->MATE Terminal. Type each of the below, one line at a time. Copy-paste the output here.

whoami
lightdm --show-config |& awk -F= '/greeter-session=/{print $2}'
cat /etc/lightdm/lightdm.conf
cat /etc/lightdm/slick-greeter.conf
cat /etc/lightdm/lightdm.conf.d/90-arctica-greeter.conf
2 Likes

I can confirm this setting works. I mean as a setting option for arctica-greeter users without need to have lightdm.conf.

1 Like

rick

lightdm-gtk-greeter

[Seat:*]
autologin-guest=false
autologin-user=rick
autologin-user-timeout=0

cat: /etc/lightdm/slick-greeter.conf: No such file or directory

cat: /etc/lightdm/lightdm.conf.d/90-arctica-greeter.conf: No such file or directory

It seems there is issue with your upgrade to 20.10. UM 20.04 uses slick-greeter for lightdm and is switched to ayatana-greeter in UM 20.10. Probably you intentionally switched to lightdm-gtk-greeter on 20.04 but even then, ayatana-greeter should have been installed as part of upgrade to 20.10. By default there will not be slick-greeter.conf but there should be 90-arctica-greeter.conf.

Anyways, lightdm-gtk-greeter is good enough. Can you please check if you have following files in your /etc/pam.d folder?

  • lightdm
  • lightdm-autologin
  • lightdm-greeter

You could do,

(base) [email protected]:~$ ll /etc/pam.d/ | grep lightdm
-rw-r--r-- 1 root root  884 Aug 14  2019 lightdm
-rw-r--r-- 1 root root  551 Aug 14  2019 lightdm-autologin
-rw-r--r-- 1 root root  727 Aug 14  2019 lightdm-greeter

I would suggest to reinstall lightdm and lightdm-gtk-greeter packages. You could either do,

sudo apt install --reinstall lightdm lightdm-gtk-greeter

Or, if you prefer, from Synaptic, choose 'Mark for Reinstallation' for both these packages. I am hoping it would work.

If not, you could try installing lightdm-autologin-greeter (probably with no further edits required, I haven't tried this).

Still no go. I have two screen shots of files in /etc/lightdm

I uninstalled all of the lightdm packages and installed the slick greeter. Everything functions the same. No difference. Should I install the arctic greeter?

Please stop flailing around and doing your cause absolutely no good. Reinstall lightdm and reboot.

To edit the lightdm.conf file, start Caja as a superuser by issuing the pkexec caja command in a terminal. Then navigate to etc/lightdm/lightdm.conf and make sure that the file looks something like my example.

Naturally you should have your user name where 'michael' appears.

Reboot and see if you are booted right to your desktop.

Edit: I meant pkexec, not pkexe. Sorry Rick.

Something else to consider is to rename the lightdm-autologin-greeter.conf file to something more like lightdm-autologin-greeter.conf.disabled so as to render it non-operable in future boots. This file is left over from a previous install of Ubuntu-MATE and really shouldn't be there.

Same thing is advised to do with the stuff in the lightdm-gtk-greeter.conf. directory. If it doesn't contain just a 90-arctica-greeter.conf file, I'd look at what else in in there and think about renaming the extra files.

followed your instructions. Still does not boot to desktop.