Login loop on Mate 16.10

Hi guys!

Since this morning I can’t login with my user, only as a guest.

.xsession-errors has this error:

/etc/X11/Xsession.d/99x11-common_start: line 5: /usr/bin/ssh-agent /usr/bin/im-launch mate-session: No such file or directory
XIO: fatal IO error 11 (Resource temporarily unavailable) on X server “:0”

I didn’t change any configs. Everything is the latest and up to date.
I tried all the .Xauthority and .ICEauthority related fixes, nothing has worked.

Any ideas?
Thanks!

1 Like

Hi @r0n1n,

try running "dpkg" per the update guide (a network cable connection is required!):

I have the exact same issue. Ran several of the dpkg commands referenced in that article, but there are no reported broken packages. Unfortunately still stuck in a login loop with the same error message :frowning:

Hi chaps,

try resetting your Ubuntu root password?:

http://www.psychocats.net/ubuntu/resetpassword

I know my root password, that doesn’t seem to be related. Unless I’m missing something. I just don’t see how it cannot find mate-session, as it clearly exists in /usr/bin and that is in my $PATH variable. Anything else I can try short of a full reinstall?

Hi @joem86,

try running "dpkg" (a network cable connection is required!) per the update guide and see if that helps?:

1 Like

This does sound like its X or ICE authority related.

Have you tried going to console (tty) at the login screen and trying startx?

CTRL + ALT + F1

And either enter just

startx

or give it the path

startx /usr/bin/mate-session

Also check for a boot failure

systemd-analyze blame

And your xorg log could have a clue

cat /var/log/Xorg.0.log
2 Likes