Long boot time advice please?

Hi all, im currently running ubuntu mate 15.04 but have a very long boot time. ive looked all over askubuntu.com and there are plenty of examples of this but no real help.

after trying many commands that appear outdated or dont run on this system i did systemd-analyze blame and got the results below... I'm very new to linux so i wondered if anyone can see something that is causing the hang up?

Many thanks, Matt

Well, my output is way different from yours.

$ systemd-analyze blame
          5.095s gpu-manager.service
          4.187s dev-sda6.device
          3.732s apparmor.service
          3.224s accounts-daemon.service
          2.891s polkitd.service
          2.860s NetworkManager.service
          2.779s udisks2.service
          2.535s plymouth-quit-wait.service
          2.257s rsyslog.service
          1.432s ntp.service
          1.322s grub-common.service
          1.278s systemd-tmpfiles-setup-dev.service
          1.224s systemd-tmpfiles-setup.service
          1.164s systemd-logind.service
          1.145s virtualbox.service
          1.115s upower.service
          1.085s plymouth-start.service
          1.054s alsa-restore.service
          1.051s irqbalance.service
          1.051s pppd-dns.service
           876ms systemd-setup-dgram-qlen.service
           785ms dev-hugepages.mount
           752ms dev-mqueue.mount
           752ms sys-kernel-debug.mount
           657ms kerneloops.service
           627ms wpa_supplicant.service
           472ms systemd-journald.service
           391ms sys-fs-fuse-connections.mount
           361ms systemd-modules-load.service
           356ms avahi-daemon.service
           342ms systemd-udevd.service
           291ms systemd-update-utmp.service
           279ms console-setup.service
           265ms systemd-udev-trigger.service
           258ms systemd-random-seed.service
           256ms networking.service
           232ms lightdm.service
           226ms dev-disk-by\x2duuid-518ad6d3\x2d248a\x2d49ce\x2d8f66\
           222ms systemd-user-sessions.service
           220ms speech-dispatcher.service
           219ms systemd-journal-flush.service
           185ms systemd-sysctl.service
           185ms systemd-vconsole-setup.service
           170ms rtkit-daemon.service
           145ms rc-local.service
           121ms ifup-wait-all-auto.service
            99ms plymouth-read-write.service
            72ms dns-clean.service
            71ms kmod-static-nodes.service
            67ms [email protected]
            59ms ufw.service
            55ms systemd-hostnamed.service
            42ms systemd-remount-fs.service
            33ms apport.service
            31ms resolvconf.service
            30ms ModemManager.service
             6ms systemd-tmpfiles-clean.service
             5ms ondemand.service
             4ms ureadahead-stop.service
             3ms systemd-update-utmp-runlevel.service
            67ms [email protected]
            59ms ufw.service
            55ms systemd-hostnamed.service
            42ms systemd-remount-fs.service
            33ms apport.service
            31ms resolvconf.service
            30ms ModemManager.service
             6ms systemd-tmpfiles-clean.service
             5ms ondemand.service
             4ms ureadahead-stop.service
             3ms systemd-update-utmp-runlevel.service

What cpu do you run? Have you tried switching from systemd back to upstart?


I really don’t have a good answer, just some thoughts.

How long is “a very long boot time”? 3-5 minutes? Is it stuck on a blank screen, for instance?

Another way to see what’s holding up boot time is to watch the console during boot up - To do that:

  1. Hold SHIFT during start-up - this reveals GRUB 2, the boot loader.
  2. Press Tab to edit the command line.
  3. Remove quiet splash at the end – This makes the system more verbose when booting.
  4. Press F10 or CTRL+X to boot, this only applies for that session, it’s not saved permanently.

This may also catch any other culprit to see what’s taking the longest – There is an old Pentium 4 machine in my house that was stuck on a “udev job is waiting to complete” and timed out after 3 minutes. I presumed the kernel/systemd used in 15.04 was having problems, so I left it on 14.04 – which uses Upstart.

Do you have an AMD or NVIDIA card? If you do, with their proprietary drivers too? gpu-manager and plymouth (the splash screen) suggests to me the hold up is because of the display.

PS. Interesting, my output suggests it could be much faster if it wasn’t waiting for the network:

      8.814s NetworkManager-wait-online.service
       854ms dev-sda1.device
       458ms ModemManager.service
       367ms accounts-daemon.service
       329ms binfmt-support.service
       328ms gpu-manager.service
       211ms alsa-restore.service
       208ms NetworkManager.service
       206ms ufw.service
       195ms systemd-setup-dgram-qlen.service
       192ms systemd-modules-load.service
       181ms kmod-static-nodes.service
       179ms apport.service
       178ms loadcpufreq.service
       170ms irqbalance.service
       169ms pppd-dns.service
       152ms apparmor.service
       152ms systemd-vconsole-setup.service
       145ms sys-kernel-debug.mount
       140ms systemd-udev-trigger.service
       138ms lm-sensors.service
       137ms timidity.service
       132ms udisks2.service
       125ms dev-mqueue.mount
       115ms speech-dispatcher.service
       115ms thermald.service
       108ms networking.service
       102ms console-setup.service
       101ms avahi-daemon.service
        96ms systemd-journal-flush.service
        84ms systemd-logind.service
        80ms media-Data.mount
        70ms ondemand.service
        68ms dev-hugepages.mount
        68ms virtualbox.service
        64ms dns-clean.service
        64ms qemu-kvm.service
        59ms polkitd.service
        52ms grub-common.service
        51ms systemd-user-sessions.service
        47ms systemd-journald.service
        45ms systemd-tmpfiles-setup-dev.service
        41ms systemd-update-utmp.service
        40ms systemd-sysctl.service
        37ms lightdm.service
        36ms ifup-wait-all-auto.service
        35ms xrdp.service
        32ms [email protected]
        32ms plymouth-read-write.service
        31ms upower.service
        31ms kerneloops.service
        30ms rsyslog.service
        29ms cpufrequtils.service
        28ms systemd-tmpfiles-clean.service
        27ms systemd-tmpfiles-setup.service
        25ms resolvconf.service
        24ms systemd-udevd.service
        23ms colord.service
        19ms dev-disk-by\x2duuid-ea2c75f2\x2d8342\x2d4459\x2dac1d\x2ddfc08c5bcb3d.swap
        18ms ntp.service
        16ms sys-fs-fuse-connections.mount
        15ms systemd-random-seed.service
        15ms wpa_supplicant.service
        13ms tmp.mount
        13ms proc-sys-fs-binfmt_misc.mount
        11ms systemd-remount-fs.service
        11ms ureadahead-stop.service
         8ms rtkit-daemon.service
         6ms rc-local.service
         4ms systemd-update-utmp-runlevel.service
         2ms plymouth-quit-wait.service
         2ms [email protected]


Now I wonder why I’m so slow. x5650

Guys, are you using the proprietary graphics drivers?
I’m using the onpen source nouveau driver for my nvidia gpu and I have this
575ms gpu-manager.service

Assuming that the gpu-manager is the gpu driver

@anon42388993 SSD Power :wink:

@Danny3 Yes, I’m using NVIDIA’s Proprietary driver.

I found a bug report too on gpu-manager causing long start-up delays, their report is caused by mesa (open source driver for ATI cards).

SSD Power

and also using proprietary nvidia driver

@anon42388993 i am running linux on a AMD quad core with radeon graphics. Not the best cpu i know but thats why i have been happy using MATE. I havent tried changing to upstart yet, in fact i didn’t even know that was an option so i’ll give it a go.

@lah7 i timed the boot at just over 3 minutes and it was well under a minute when i first installed MATE 15.04 a few months back. I am using the proprietary AMD drivers so would you suggest i look at using open source? I have tried removing ‘quiet splash’ from the command line in the past but for some reason i cant boot out of the editor so i have to do a hard reset which is frustrating to say the least!

Do you observe any disk activity while starting up? From the sounds of 3 minutes, it sounds like a timeout while waiting for a specific job to finish (assumption from past experience on another PC taking forever to load)

Removing “quiet splash” from the boot options would reveal if this is the case. It should boot after pressing F10 (or FN+F10 if on laptop) or CTRL+X after deleting the 2 words, not sure why a hard reset would be needed. :confused:

As for the drivers, you could give the open source drivers a test, but we haven’t quite found evidence that these are definitely the culprit, as it takes 22 seconds for the service to start… but it could be holding everything up after it’s started?

well, i ended up messing about with updating grub and changing various settings and basically making things a lot worse so i saved all i needed to an external hard drive and did a compete fresh install of ubuntu MATE 15.10. All working very nicely now and at the speed that i had come to expect :slight_smile:

Thanks for all the advice