Loss of control of Mouse and Keyboard when right clicking a file

I’ve had this happen several times when I would right click on a file to display properties I would suddenly loose the ability to click on anything including the close window button and anything in the panel and anything in Docky (but strangely when I would move the mouse down Docky would pop up but clicking did not open anything in Docky) and I also loose control of the Keyboard except for Ctrl Atl and any of the function keys so I would have to hit Ctrl Alt and F-4 to then have the choice to hit Ctrl Alt Del to do a proper shutdown or hit Ctrl Alt F-7 to go back to the desktop so the last time this happened I did just that hit Ctrl Alt F-7 and went back to the GUI but then the desktop was corrupt and I still had no keyboard control or ability to click anything or use the keyboard other then to do a Ctrl Alt F-4 and then Ctrl Alt Del to reboot less abruptly then hitting reset or forcing a power off by holding the power button till my computer turned off. Since Then I discovered if I hit Ctrl Alt F-5 it will give be a command prompt where I can type shutdown or reboot to reboot that way figuring it’s more safe to do it that way then to do a Ctrl Alt Del. This time I had not put my computer ito Suspend and any time since powering it on, I had just let it stay on for 8 + hours while some large files were downloading and I went out and when I came back and right clicked on a audio file to get it’s properties that is when I lost control of the Keyboard and ability to click anything.
I’ve also gotten this problem when hitting F-3 to get that duel pane window to copy or move a file from one directory to another.
I had a even worse problem with Cylon Linux 12.04 where my computer would lock up solid when I would do something with the mouse related to opening a menu or right clicking on a file. My current problem basically is the same problem but not as sever because at least I can properly shutdown but there is still the fact that if it happens if I have any unsaved work I will loose all that because I can’t use the mouse to save what ever file I have opened that has unsaved data since I can’t use the mouse to select that program and save the file, also if a file is downloading I will have to guess how log to wait for it to finish downloading or just reboot and re download it once my PC finished booting again.

For Mate Tweak in Windows I have Window Manager set to "Macro (Software Compositor) with Enable Animations checked and Do not show window content when moving windows un checked. Under Panels I have Ubuntu Mate for Panel Layout.

This is annoying, I installed Linux to get away from the instability of Windows if I wanted stability problems as well as security and virus problems I would have just stayed with Windows 7 or switched to Windows 10.

Sounds like a problem with bad memory… What is your system? CPU? Laptop or desktop?

1 Like


Please can you open Terminal and enter

inxi -Fxz

Paste results between <code> </code> tags, thanks!

Since you mention two other OS (including Windows) also proving to be unstable, seems there may be a possible hardware issue.

Please also try running Memory Test (memtest86+), found under GRUB boot menu (if you don’t see GRUB screen while booting, hold down Shift key).

Have you tried another mouse, in case mouse has developed a fault and is providing conflicting / constant signals while right mouse button is pressed?

Other Dave beat me to it! :slight_smile:

1 Like

I hope I did this right it seems to be displayed ok and not formated wrong.

I did do a Memory Test with both the Memory Test both with the one included in Linux at the boot manager screen and a Geek Squad Memory Test Program that I ran all night long and both completed without any errors.

When I referred to Windows and it’s instability I meant how it’s unstable and insecure by nature and not because it’s specific to my system. I never had Windows 7 crash on my current system because I don’t use it enough for it to have a chance to unexpectedly crash.

My system is one that has built in video and uses part of the system memory for the video memory I thought about buying a entry level NVIDIA PCI Express video card thinking maybe my problem is because of memory leak into the shared system memory used fro the graphic chip set but I never figured out what a decent card would be. I have no desire to play games on my PC so I don’t need a $ 400 video card just a entry level one that is stable and can handle #-D desktop effects watch videos and surf the INTERNET.

System: Host: Taslims-Ubuntu-Mate Kernel: 4.4.0-28-generic x86_64 (64 bit gcc: 5.3.1)
Desktop: MATE 1.12.1 (Gtk 3.18.9-1ubuntu3)
Distro: Ubuntu 16.04 xenial
Machine: Mobo: ASUSTeK model: P8B75-M v: Rev X.0x
Bios: American Megatrends v: 1002 date: 10/16/2012
CPU: Dual core Intel Core i3-3220 (-HT-MCP-) cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 13200
clock speeds: max: 3300 MHz 1: 1609 MHz 2: 2045 MHz 3: 2221 MHz
4: 1699 MHz
Graphics: Card: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller
bus-ID: 00:02.0
Display Server: X.Org 1.18.3 drivers: intel (unloaded: fbdev,vesa)
Resolution: [email protected]
GLX Renderer: Mesa DRI Intel Ivybridge Desktop
GLX Version: 3.0 Mesa 11.2.0 Direct Rendering: Yes
Audio: Card Intel 7 Series/C210 Series Family High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.4.0-28-generic
Network: Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 03:00.0
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac:
Drives: HDD Total Size: 3160.6GB (57.7% used)
ID-1: /dev/sda model: ST1000DM003 size: 1000.2GB
ID-2: /dev/sdb model: ST3160023A size: 160.0GB
ID-3: /dev/sdc model: SAMSUNG_HD204UI size: 2000.4GB
Partition: ID-1: / size: 95G used: 42G (47%) fs: ext4 dev: /dev/sda5
ID-2: swap-1 size: 3.95GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 29.8C mobo: 27.8C
Fan Speeds (in rpm): cpu: 0
Info: Processes: 218 Uptime: 28 min Memory: 1239.0/3632.1MB
Init: systemd runlevel: 5 Gcc sys: 5.3.1
Client: Shell (bash 4.3.461) inxi: 2.2.35

Thanks for posting the results (formatting is fine). Good to hear the system memory is passing tests without issue! :slight_smile:

Looking at your system specifications, one of the first things I notice, there have been several BIOS updates since the version you are using (1002), most mention “Improve system stability”. If you feel confident doing so, I would definitely recommend updating to the latest version (1701). If you have any doubts, contact a qualified PC technician and let them perform the update for you.

For your current usage requirements, there shouldn’t be any issues using your iGPU (integrated GPU), or which necessitates purchasing an NVIDIA dGPU (discreet GPU). So saying, if you decide to proceed, there are several fairly powerful low priced NVIDIA GPUs. Look for recent versions (preferably 700 series and above) with 2GB or more.

Lastly, this shouldn’t make any difference to stability, you may also consider updating to MATE version 1.14.1.

I did not know there were updates to my BIOS, the last time I checked several years ago I had the latest revision and figured ASUS no longer supported my Mother Board so I never bothered to check again. I hope it does not require booting from a floppy because I don’t have a floppy drive or any floppy disks but I think Asus has a live BIOS Update program that runs in Windows and I think it even automatically checks to see if you have the latests version and updates it if you don’t.

As far as Graphics cards go isn’t 1 GB enough for 16 million colors? I’ve only got 512MBs reserved for the Video Memory and photos and movies look just fine.

Just updated the BIOS

Machine: Mobo: ASUSTeK model: P8B75-M v: Rev X.0x
Bios: American Megatrends v: 1701 date: 08/06/2014

Had a few scares when updating when at first it seemed to hang at %100 and thought to my self that it should not take so long to updated the BIOS so I clicked the flash button again and then when I got the working spinning circle I thought uh oh did I just screw up?
But then after about 2 minutes it said “The system needs to be restarted to complete the update” so I clicked OK and then Windows 7 rebooted and my PC turned off and back on beeped with no video, turned off again and back on beeped with no video so I thought I had hosed my Motherboard but then it turned off a third time and came back on and then got video and I noticed the BIOS screen had a different look so I guess it added some new features.
But it all turned out OK as you can see sine I’m able to reply to this post. I hope this fixes my problem.

Thanks for all your help.

Great to hear the update completed. Only usually recommend BIOS updates for those experiencing issues, or for hardware compatibility fixes, and always give a warning ‘If in doubt, contact a qualified PC Tech…’.

Thankfully, with newer motherboards, the need for floppy disks to perform BIOS updates has been superseded, either updating though an OS, or allowing the use of USB flash drives. Newer ASUS motherboards also offer EZ Flash 2, you can backup and update the BIOS from within the BIOS.

In case you need to perform further updates, or look at flashing the BIOS from within the BIOS, here’s the link to your manual, scroll down to section 2.1.2 (page 48)

One thing I always do after updating a BIOS, (only do this if you know how to enter correct settings afterwards!) is to reset the BIOS back to defaults upon first reboot after flashing, then enter all settings required, if in doubt, do not proceed!

If the system doesn’t restart after flashing, seems to reboot a couple of times, it can be if an incorrect CPU/memory BIOS setting has been detected, a few settings will be attempted until a stable setting is found. No display issue can happen if a dGPU is fitted, the BIOS can be set to use iGPU, dGPU, or Auto, Auto setting sometimes chooses a headless device (GPU without monitor connected), hence no display (shouldn’t have happened in your case).

As for 1GB GPU, since there’s only a tiny difference in price between 1-2GB, best to be future-proof. Other than gaming, at some point you may find you want to try GPGPU, or drive multiple 4K screens.

That was the program I used, I installed it from the Support DVD Disc that came with my Motherboard figuring if I use the Asus supplied Disc it will be the correct or proper or supported way to update the BIOS and the most easy way where I don’t have to worry about wondering if I was doing it correctly if done manually and I assumed the program would check the file to be the proper update file so I don’t flash the wrong one and render my system bricked or un bootable, I assume it verifies the correct files is being loaded before it flashes the BIOS. I think my Motherboard supports updating the BIOS from the BIOS Setup screen but I preferred to use the Windows program that walks you through it step by step and is designed for non technical people.
I remember the days when you had to order a new BIOS Chip to update the BIOS on your Motherboard.
I’ve customized my setting a little bit, I have it set to be able to turn on the system via a key combination on the Keyboard (Ctrl Esc) or by moving and clicking the mouse plus I have the PS/2 port set to full initialization because I have one of those old IBM 1391401 Model M Clicking Keyboards that don’t have the Windows Keys that was manufactured on 9/21/1990 and was still Made In America because it gets a Keyboard Not Found Error from the BIOS on boot up but if I don’t have it set that way but once the system boots it works fine and if I do a Ctrl Alt Del after the GRUB Boot Manager screen comes up I can get into the BIOS but I like being able to get into the BIOS setting before that so I set it to full initialization.

Thanks for the link to the Manual for my Motherboard because I lost the physical paper copy of the manual.

Well, So Far So Good, I have not had the problem with the loss of mouse yet and I’ve suspend several times, right click many many many files and hooked up my cell phone several times and opened a duel pane window and copied files from one pane to the other with no problems. But then every time I’ve said or thought that in the past almost immediately after that I would have the problem but lets just hope that never happens again.

Thanks for the suggestion to update my BIOS. I guess since it said it addressed stability problems that is why it now seem to be running just file.

I have not tried running Virtual Box yet and then suspending but I might try that after a few more days testing my system.

Are you using Compiz as your window manager? I had a similar if not the same issue. I had to change to Compton (which had it’s own issues with the lock screen). I noticed a couple of weeks ago there were updates for Compiz that seemed to have alleviated the issue and have been back to running Compiz for a while since.

Also, I’m running an 8800GT which uses the Nvidia 340.96 driver.

I guess I'm using Macro (Software Compositor). When I tried selecting Compiz it screwed up my system and I had to do a Ctrl Alt F-4 and then Ctrl Alt Del and luckily when my PC rebooted it was back to normal on Macro (Software Compositor)

After I updated my BIOS my problems seems to have gone away I have not had any issues with the mouse or graphics except when I tried that switch users option so I will just not use that since I have no use for it anyway and was just experimenting.