Lost my Printer Utility

I lost my printer utility. It doesn't appear on the launcher menu any longer and the printer does not respond to print requests from apps (i.e. Libre Office) when I open LibreOffice Writer for example and open a saved document and select "Print" The printer shows up as MFC-L2705DW but noyhing happens
Brother MFC-L2705DW
Connected directly on LAN (cat5)
Shows as a device on the router.
Shows up on apps as an installed printer
Works fine on Windows

Could this be a CUPS problem?
BTW - printer has worked as it should for many years.
Printer stopped working when I installed MATE 1.26.0
I reinstalled MATE 1.24.0 still no joy.

Any suggestions to bring back my printer would be appreciated.
8/21/21 - additional info. I noticed that the printer indicates that its in "Deep sleep" mode. Doesn't affect operating normally in Windows OS. but UM still doesn't print. I guess the system in either case should send a command to wake up.

Hello spanky

I have an Brother MFC-J6930DW conected via LAN. I have also updated to MATE 1.26.0. My printer continues to work as it did before the MATE update. :slightly_smiling_face:

Did you power cycle the printer?

I did power cycle the printer. No Joy.

It may have nothing to do with the upgrade to 1.26 but I did revert back to 1.24 due to other issues such as system hesitancy (i.e. a command to open an app from the launcher took over 30 sec. occasionally.