Lost ownership of storage drive UM 20.04

When saving a file from a website, I can save it to my home/Downloads, but I can't save it to my separate storage drive it comes back with "insufficient permissions"
I have gone into that drive as administrator and verified that all settings are me but still can't create a file on that drive...I just installed ubuntu pro for the long term security support yesterday.
Did I security myself out of my storage drive? How can I fix this?
Alternatively, how do I uninstall Ubuntu Pro?

Quick question are you able to copy files from say Desktop or Downlads(example) to the separate storage drive? Secondary question what browser are you using and what/how installed ie: snap, flatpak, .tar, deb? I have Firefox .tar and normally download everything to Desktop. In settings changed to removable drive and it downloaded to it.

1 Like

Can't copy to storage drive, don't have permission, it's not a removable drive, it's a separate internal drive.
The browser is Chrome, but same result with firefox. I can save from browser to downloads but can't save to storage drive or copy from downloads to storage drive through file manager.
Firefox came with system install, and I think I used software boutique to install Chrome.

1 Like

OK my reference to removable drive was how I checked on my system. Sounds like a permission problem but you stated you checked. But also check as user. Are you totally unable to copy anything from another location to the secondary drive?

1 Like

completely unable, and my feeling is that ubuntu pro added a security measure to prevent copying from the system to an "outside" destination, because I can move/copy things from/to any directory in the drive Linux is installed to.

I installed the pro because I like 20.04 and I've had printer issues on a couple of other machines I installed 22.04 on, so I want to keep 20.04 as long as possible, with security updates.

I just tested an external drive and it gives no issue with creating/writing a file, so it's just that internal storage drive.

Ok with more information were you able to use the storage drive in question and after going Ubuntu Pro you couldn't.
Maybe here Step 01 (edit deleted item to correct) to check permissions.


Understand reasoning to keep as Ubuntu Pro extends security updates for 5 additional years over the 5 years included with the original OS.

1 Like

I did permissions as indicated in that tutorial, it showed changed, but reverted when I tried to save to or copy to that drive and came back with the same permisisons error...
I did an unmount and remount:
sudo umount /dev/sdc1
sudo mount -o rw /dev/sdc1 /mydirectory

and came back with this:
self@OptiPlex-7010:~$ sudo mount -o rw /dev/sdc1 /mydirectory
The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Falling back to read-only mount because the NTFS partition is in an
unsafe state. Please resume and shutdown Windows fully (no hibernation
or fast restarting.)
Could not mount read-write, trying read-only
ntfs-3g-mount: failed to access mountpoint /mydirectory: No such file or directory

I have windows installed internally on another drive and I share that storage drive with it.
Could this issue be coincidence and the storage drive is dying? There is no windows anything installed on that storage drive, it's ntfs so it can be read by windows too.
I will have to test the drive and get back to you...thanks so much for your help thus far

I've never had an issue like that before, evidently Windows, on an entirely different drive caused it, and it coincided with my installing Ubuntu Pro...I fixed the windows issue (bad update) and now the storage drive can be written to from this Linux installation.
sda is Linux, sdb is windows, and sdc is just storage accessible to both. I'm still confused but it's working now so problem solved.
I appreciate your time and effort, and I apologize for wasting it.
I did learn something useful to me from the link you provided that will help me in the future.
Thank you :slight_smile: