Lost right click on screen

I normally use a 19" monitor, but today decided to try a 21" just for fun...turned out to be no fun at all. Everything was working great, beautiful picture, nice color, etc. I decided to change the resolution, just to compare; Bad decision.

In the "old" days, if I wanted to change desktop background, I right click anywhere on the screen and the window opens where I go to backgrounds. I do (did) this often.

The way to get there now is >menu>appearance>background It's not so terrible but I liked the old(easy) way much better.

Now, when I right click in Mate, nothing happens. Mouse works fine in Win10, Plain Ubuntu and Mint Mate. Ubuntu Mate, which I use most of the time, is the only one that went bad.

Tried: the old monitor, 3 different mouse, timeshift, and rebooted a few times. I can’t imagine how I could have done this by changing screen resolution ONLY in Ubuntu Mate?

Does not apply or work for me ( mine worked with "show icons" off)

Possibly restore partition from Clonezilla, but rather not go through that if I don't have to. Thanks in advance for any response.

What resolution were you on before that fateful resolution change that sent the universe out of karma? :slight_smile: What resolution did you change to? Does the right-click menu reappear after you switch back to the previous resolution?

Did your desktop icons (if any) also disappear with the right-click menu? Can you right-click in a normal Caja window (as opposed to on the desktop)?

Will anything change if you run this command:

caja --force-desktop

How about this:

gsettings set org.mate.background draw-background true

If you create an icon on the desktop, then right-click on that icon, does the right-click menu appear for that icon? Heck, does the icon itself even appear?

Does a popup menu appear while you press and hold down the right button, but disappear after you release the button? I've seen that happen.

Collect all those data points, and we'll have a much better idea of what the problem is and how to treat it. Thank you.

Thanks Gordon!
I'll do my best here, as I'm back to my old monitor, which does not do the same res, and I don't memorize these numbers. I hope you read my post all the way through!

#1 The "bad" monitor was set 2 res higher than 1280 x 1024 (now). when I was in the highest it all worked fine, when I went one step down, that's when the Ubuntu Mate became Ubuntu Mean.

#2 As stated before, going back changes nothing. I am back in the original setting now, with no right click for desktop with Mate only.

#3, #4 the caja command brings up my home folder, the gsettings does nothing at all, both executed from the terminal.

#5 I have desktop icons turnedd off (with the help of someone else on this board)... and if I turn them on, then, yes I get this function back... not a good option...I don't want icons on Desktop. It worked OK with icons turned off before. (I even referenced an article posted here in the post)

#6 No right mouse = nothing = when I press the right mouse button nothing happens.

Thanks for trying.

I knew I have to have "show icons" in tweak. that's the easy answer.
But, just 2 days ago and forever(?) before that it worked with the "show" option turned off. I can't imagine what changed.

I don't know how it's possible for a monitor swap to do this...but it is so. I don't have time to find out, as it's not crucial. I thought it 'd be easy!
Thank you for response and I consider this question answered.