MacBook Freeze After 20.04LTS->22.04LTS (Nvidia?)

I upgraded this old MacBook 7,2 to 22.04LTS and it doesn't Suspend or wake, requiring Power button hard boot. It also randomly freezes and again requires hard boot. I've seen some mention online, of a possible connection to the Nvidia chip and a driver update that's in 22.04. Maybe also a newer update of Linux kernel and/or Nvidia driver that fixes it.

Suspend just blacks the screen but the fans keep running so there's clearly no sleep and no change with any keystroke or key combinations (e.g. Ctrl-Alt-F1/2 suggested by some). It's oddly working so far in this session of 10 minutes or so, having repeatedly frozen after a minute or two yesterday, so maybe there's some specific input that triggers the freeze/blackout. When it freezes during a session, the screen stays on and mouse moves but it's unresponsive.

After one of the hard reboots I got the UbuMate "Send Report" and did it, but no idea where that went. Maybe there are specific instructions somewhere on how to access the system and/or crash logs if that could help. Any suggestions or ideas much appreciated, including how to revert to 22.04 (did a Timeshift backup before Upgrade).

System: MacBook7,2 ~
22.04.1 LTS ~ 5.15.0-47-generic x86_64 ~ MATE 1.26.0 ~
Intel® Core™2 Duo CPU P8600 @ 2.40GHz × 2 ~
NVAF (Nvidia GPU which some say is the root of all evil)

1 Like

Update: I've just realized that yesterday's repeated freezes after hard boot were after many attempts at Suspend. They got more frequent and earlier in each session. Today I've been doing email in Tbird, then posting here via FFox, quit FF and then reopened it and did another task on a different site, quit again and then another FF now to post this - all with zero problems so far. The difference a day made is yesterday's shutdown w/o Suspend attempt. In short, it seems yesterday's freezes were due to repeated attempt at Suspend. Needless to say, when done with this session will end with a ShutDown.

QUESTION: How does one Hibernate in 22.04? I'd like to try that, to see if it avoids the freeze syndrom and is a quicker way to start a session than boot. I'm going to try the instructions here, and will report back...

1 Like

OK, so Hibernate seems to be off the table. I used this:

systemctl hibernate

The system immediately went black with the fan running and no disk access sounds. After two minutes I did a hard boot.

I noticed when booting again, a couple of text lines flashed top-left far too quick to read. I did another shutdown & boot while recording the screen and managed to nab this 2-line message twice. Once before the round UbuMate logo with marching dots below it, and again just before the few lines of brief auto-login notification. This error didn't flash before ugrading 20.04LTS to 22.04LTS, and there was no hardware problem before upgrade so presumably a hard/firm-ware conflict? Here's that 2-line error message in case it means something to anyone:

This seems to be related to graphics, since it crashed once trying to use an emoticon here and crashed just now when I opened gThumb to copy/paste the above image here (this time I drag/dropped the file). I also got the UbuM "Send" crash report notice again and sent it at about 1:26:26pm Pacific in case that's useful.

Any ideas/pointers?


OK, I gave up on this for now and have managed to restore the Timeshift 20.04 backup from just before the "upgrade" nightmare. I've also turned off upgrade notification in Software Updater. Since 20.04 still gets standard support for a few years I'll wait and see if something turns up. Maybe occasionally rummage the web for someone who's solved it and post any news here. Thanks for reading this, and do feel free to share any ideas anytime. :slightly_smiling_face:

1 Like

Fixed. First off, the downgrade worked fine. Oddly, my wife's identical model MacBook upgraded just fine. Anyway, when the "upgrade or die" message came in from UbuM I upgraded again, and it's working perfectly. Maybe something went awry in the first upgrade, I made some tiny boo boo, or the problem's been fixed in the final release. Regardless, I wanted to let any other fans of antique MacBooks know that it's probably safe to upgrade now.