Main Menu editor destroys menu with non-ASCII characters

I ran into a nasty bug the other day which I mentioned here:

I had installed a new game on Steam, and it's menu entry is Life Is Strange™. Only that making any modifications would "self distruct" the entire menu since it couldn't process a non-ASCII character (™). Deleting the character from the launcher fixes the problem.

The affected system is Ubuntu MATE 16.04 with MATE 1.14. The language is en_GB in case that makes a difference.

It is strange... Fortunately there are backups of the menu to restore. Does this happen to other releases/MATE versions too.. or could it be something else related to that launcher?

I tried to reproduce that but couldn't:

It appears in the menu OK, did you try editing the menu (anything) using the Main Menu utility? That’s what triggers the bug.

Yes, added another item, unchecked stuff, even deleted one item, still couldn’t trigger the bug.
Were you running the LTS?
Cheers

I am running 16.04 LTS, with MATE 1.14. Are you?

16.04 w/ MATE 1.12.1

Well, seems like a bug in 1.14 to me :wink:

It was a bug in 1.14, and it’s since been fixed in newer releases of MATE :slight_smile: