Main menu malfunction

I’m having a problem with ‘Places’ on the ‘Main menu’ interface,
Main menu’ i.e. Applications - Places - System - on the top of my screen.
Whatever profile I choose, ‘ubuntyMATE’, Fedora or GNOM, or whatever.

My problem is that when I click on ‘Places’ > and any of… ‘Home Folder’, Desktop, Computer, Drive1, ‘Blank DVD-R Disk’, or Network, whichever, the VLC media player is activated.
This was not the case a few hours ago, everything functioned correctly.
Note: It played a video track that was on my Desktop, removing the track did not fix the problem.
However, If I remove VLC media, EVERYTHING WORKS FINE.
When I re-install it, my problem is back.

I have no idea what I did to cause this problem!

Any ideas on HOW to correct this?

Please keep answers in NON-Geek, as I’m an OAP and far too old to understand Programmer’s terminology or abbreviations.

Please help!

Before I assume anything, could you open mate-tweak and tell us what panel configuration you have enabled, as well options therein?

Also, type in a terminal xdg-mime query default inode/directory and tell us what that spits out. It should be caja-folder-handler.desktop. xdg-open should then use caja-folder-handler.desktop if this is the case, though I don’t know all the specifics about the default menu stuff in mate-tweak's ubuntu-mate profile.

(Also, it seems markdown with single-grave code blocks in-line with text on this website is incredibly broken for some reason. And sorry for the geek-chic answer; blame Linux, not me.)

Hi @fatherjack,

what version of Ubuntu Mate are you using?.

Have you run a full system update?:

I’m running ubuntuMATE 16.04

Thank you for your response.
I’m running MATE 16.04 and It dose not matter which Interface I use, the problem is univerasl.

Using the MATE Tweak tool,
I set the Interface as follows…
1-Panel: √ Ubuntu MATE
2-Panel Features:, √ Enable indicators, and √ Enable keyboard LED
3-Icons:, √ Show icons on menus, and √ Show icons on buttons
4-Context menus:, √ Show input Method menu in context menus, and √ Show Unicode Control Character menu in context menu.
5-Toolbar:, √ Style: = √ Text below item, and √ Icon size: = √ Small

great to hear from you “tiox”.
from my Terminal
MATE:~$ xdg-mime query default inode/directory

the response looks wrong?? yes!
So, what do I need to do to correct it?

Let’s try the easy method first; In a terminal, do the following;
sudo apt-get install --reinstall ubuntu-mate-default-settings

That package should provide the solution you’re after. If xdg-mime query default inode/directory doesn’t yield caja-folder-handler.desktop then you might need to do it the slightly-harder way;
xdg-mime default caja-folder-handler.desktop inode/directory

After, you can see if saved searches are going to pull the same crap;
xdg-mime query default application/x-mate-saved-search xdg-mime query default application/x-gnome-saved-search
If they don’t match inode/directory, then just do the same thing for them as you’d need to do to fix inode/directory.

(You can set multiple minor/major arguments to use the same desktop file, as follows;
xdg-mime default caja-folder-handler.desktop inode/directory application/x-mate-saved-search application/x-gnome-saved-search)

Lastly, figure out what happened that set vlc.desktop for inode/directory in the first place, and don’t allow it to happen ever again.

1 Like

No follow-up hm? Shame, really, I wanted to see if he managed to sort his stuff out.

Sorry for the delayed response.
Normally I spend most of my day doodling on the computer, but I took some time-out, FORCED socialization.
I’m sorted. great stuff.
Thanks for the responses and many thanks for all your help.
I’ll try to behave in future, i still have NO idea how the error was caused.
‘Tiox’, …“you-de-man”.

You have to excuse my last post. I fixed it, but things get confusing for a slightly-dyslexic brain like mine, which is why I drop extensions and swap commands on occasion. I tried to clean that up best I could in my last edit to it. View the edit history and you’ll see just how badly I botched it the first time around.

I’m afraid… “Είναι όλα ελληνικά για μένα”
(“it’s ALL Greek to me”) and I’m not very Software-savvy, even though I’m using Linux flavours for almost 10 years. I’m just glad you’re there to help.

P.S. (re another MATE posting) I’m also happy that you left Synaptic ‘up there’.
Thanks again.