Map volume keys from 0 to >100


I cannot manage to map my volume keys to go above 100%. I can do it from command line but I would like to press the volume up key until it reaches 150 for example. Also, if you press volume up when manually set to 150 it automatically resets to 100. I know Ubuntu Desktop does this by activating allow-amplified-volume which I tried as well in dconf-editor but without success. Any idea if this can be achieved in mate? I'm using version 20.04.

Hi potac, welcome to Ubuntu-MATE community.

First to answer your question:

I cannot manage to map my volume keys to go above 100%.
Any idea if this can be achieved in mate?

Not that I know of, it may be possible with a hack but it is also not really the best way to solve the problem.
Boosting the output-stage beyond 100% is a useful (and quick) hack in some cases but (technically) not a good solution.


If you want to boost the ouput volume beyond 100% because your input volume is too low, you're actually trying to solve the problem on the wrong end of the audio-chain.

Your audiosource should give you the tools to boost the levels to nominal volume ( 0dB peak ).
I don't know what your audiosource is but if it is a mediaplayer like VLC you can boost it to 200% (with , of course, the possibility of loads of distortion if your peaklevel gets above -6dB)

EDIT: If your audiosource doesn't give you the possibility to change volume above 100% or change volume at all you can install PulseAudio Volume Control (see answer of @snow_dog ) and use the playback sliders to fix this.

If you want to boost the ouput volume beyond 100% because your output volume is too low while your input volume is OK, your output amplifier is definitely not up to the job and will go into clipping like mad. I wonder if it will survive that for long.

If you want it louder without giving up dynamic range and without loads of distortion you need more headroom:

  1. If you are listenin on PC-speakers you might turn the volume up on your PC-speakers.

  2. If you are listening build-in laptop speakers, install pulseeffects.
    sudo apt install pulseeffects
    because almost all laptop speakers are so incredibly bad you probably need more than just boost the volume. You will probably need a parametric EQ and a compressor to just make it bearable.

  3. if you are listening on a laptop through headphones you might want to use a seperate headphone-amplifier because there are a lot of laptops out there that have incredibly inadequate output-amps that are, while OK to use with simple earplugs, not nearly-enough to drive a good quality headset.

tl;dr: If you don't care about any of this and only want a quick solution,
install pulseeffects
sudo apt install pulseeffects

tl;dr: If you want the right solution, install PulseAudio Volume Control.
sudo apt install pavucontrol

EDIT: thanks @snow_dog

Good luck and happy hacking :slight_smile:

Hi potac,

Probably, I had similar situation as yours. In previous version of Ubuntu, I was able to adjust volume over 100%. However after switching to 20.04, there is no such option by default and due to some reasons, volume level was a little bit low when I used Chrome as a browser.

I solved this problem by installing “PulseAudio Volume Control” from Software Boutique and adjusting Playback level to 115% only for Chrome but keeping 100% for the rest of applications.

1 Like

Hi @potac,

snow_dog 's solution is better than mine, his description is also exactly the right way to do it. I re-edited my answer to reflect that.

@snow_dog, big thanks for mentioning this, i totally forgot about “PulseAudio Volume Control”.

1 Like

Hey @tkn and @snow_dog. Thanks for the suggestions. Unfortunately with pulseaudio volume control if I increase the playback for Mozilla to 150 for a youtube video, as soon as I refresh the page or change video it is reset to 100. This is a pain, don't get why they don't enable going higher 0dB. I understand that in theory you shouldn't go pass the nominal audio level but there are some videos on the internet that are really low compared with others. This is mainly for browser videos btw. In VLC I have no problem as like @tkn said I can boost it within the same application.

That seems to be a known issue with firefox:

Also check this (important)

You can enter about:config in the addressbar of firefox and increase the default volume:
search and select media.default_volume
change 1.0 to 1.5 or whatever you like

Maybe this is a nice workaround for the moment ( if it works at all):

If all else fails:
To permanently boost your master volume beyond 100%, just to compensate for the cockup of mozilla:
sudo apt install pulseeffects
and choose any of the plugins that allow you to do so.
i.e. limiter, maximizer, auto-gain or compressor
whichever you find the most convenient to work with.

The best solution would be: drop Firefox and start using Brave


Just want to add this: I discovered that youtube keeps on setting the volume at 60%-70%
To workaround that idiotic behaviour:
media.default_volume 5
media.volume_scale 5

Ofcourse it doesn't solve the forementioned problem but at least it keeps the volume at 100% when using youtube.

Thanks! That's really helpful