Marco compositor screen decorations missing on reboots

Since yesterday, on every reboot, I have no mouse pointer available - it is possible to get a cross to appear by opening a terminal on screen (by assuming the mouse position as icons expand on mouseover). No border decorations are available on any opened items. This led me to look into the compositor which has been working perfectly for many months. I get this message on screen.

However, switching to any of the alternatives available gets the compositor working again for that session. I installed and tried with metacity too but still get the same problems next reboot. Any ideas on what I need to change or re-install etc?

Debian Stretch
Mate 1.14.1
Kernel 4.6.0-1-amd64 x86_64
Processor: Intel® Pentium(R) Dual CPU E2200 @ 2.20GHz × 2
Let me know if you need any other info.
All of the compositors below except for mutter work for the session but all fail on reboot.
No Compositor
Software Compositor
Compton Gpu Compositor
No Compositor
Software Compositor
Compton GPU Compositor

Mutter (Elegant GPU accelerated desktop effects) Crashes out.

Things I’d try:

You can also try dconf reset -f /org/mate/marco to reset marco settings and then using alt+F2 run marco --no-composite --replace. If it worked but on reboot the problem presists then create a .desktop entry with Exec=marco --no-composite --replace and put it under ~/.config/autostart until you find a solution.

Okay, after many hours of trying to sort this out, I nuked the user (after backing up all data) and re-created them. Seems to be back on track now.

Cheers, Dom.