Mate 16.04 Broadcom wifi unclaimed on HP EliteBook 2570p

The wifi has stopped functioning properly. I don’t know if it’s related, but I was installing and running phoronix-test-suite (for another purpose) just 10 minutues prior to the issue appearing. Until now, there has never been any issue with the wifi driver on this machine.

Output from lshw -C network (in addition to a functioning ethernet)
*-network UNCLAIMED description: Network controller product: BCM43228 802.11a/b/g/n vendor: Broadcom Corporation physical id: 0 bus info: [email protected]:24:00.0 version: 00 width: 64 bits clock: 33MHz capabilities: pm msi pciexpress bus_master cap_list configuration: latency=0 resources: memory:d4400000-d4403fff
and from lspci -vvnn | grep 14e4
24:00.0 Network controller [0280]: Broadcom Corporation BCM43228 802.11a/b/g/n [14e4:4359]

I’ve tried purging bcmwl-kernel-source and reinstalling; that didn’t work.
There is a physical wifi-switch that seems to insist on being off.

Hi @fnugus,

check in BIOS to see if you have WiFi switched to remember last state or it is switched to Off by default.

Also, try using a different kernel at the GRUB menu by selecting a previous kernel and see if the same thing happens, choose "Advanced options for Ubuntu" at the menu. :smiley:

I checked the settings in the BIOS, and they all seem fine.

Somehow, I don’t seem to be able to get the grub menu on startup. Esc gets me to ‘startup menu’ quoth various system diagnostics and boot device order as well as the BIOS.
Edit: I managed to get the grub menu to disappear. Booting in a different kernel does no difference. I also went to recovery mode and tried the option with networking, but it seems like it got stuck somehow.

When you started networking in recovery mode, did you use a network cable connection?, it won’t work with WiFi unless you really know what you are doing!. :smiley:

See the update guide for more info:

I tried booting in recovery mode with cabled connection; this worked. I tried the dpkg option, which did something with some packages. However, the wifi is still not working.

I noticed in the output from the lshw command that there is no driver or anything specified under “configuration:” I suppose this is either a symptom of or related to the issue.

Is there any way to “claim” the network, and force it to use a driver?

Edit: When I go (through the graphical interface) to System -> Preferences -> Hardware -> Additional Drivers, it lists the proprietary driver as being in use. However, the issue is still present.
Also, a side question: contacting the technical service of the reseller resulted in them asking me to go and “reset network” (they assume a Windows installation). Is there an equivalent action available on Mate?

Edit: When purging and subsequently reinstalling the bcmwl-kernel-source, there is the following error:

modprobe: ERROR: could not insert ‘wl’: Exec format error

This thread seems to suggest you need to install linux-headers-generic before reinstalling bcmwl-kernel-source. Did you do that?

You can also download and try the following package:

https://ubuntu.pkgs.org/17.10/ubuntu-multiverse-amd64/broadcom-sta-common_6.30.223.271-7_all.deb.html :smiley:

@ouroumov I tried that now. It didn’t work either. I still get the modprobe error when reinstalling the bcmwl-kernel-source.

@wolfman I followed the link and installed the package through the official channels, as they write that it should not be installed manually. It didn’t work. Should I still try to download the ubuntu-multiverse deb file and install that directly?

Hi @fnugus,

I wouldn’t see any harm in installing the package manually, it will either work or not and you can always remove it afterwards should it not work!. :smiley:

Hereby tried. Still didn’t work.

Searching around the internet seems to suggest that others have had the issue (on Windows machines, though), where the solution in some cases has been to use something called HP Assistant (which is for Windows), or updating the BIOS via a FAT32 flash drive.

I’m thinking I might attempt the BIOS update.

Anyway, is there a way of determining for sure if the hardware is broken? I’d like to be as sure as possible before potentially sending it in for service.

You can try a different Linux distro in the form of a Live CD and see if the hardware is addressed and that way you might be able to determine as to whether or not is a broken piece of hardware or not?:

Try Manjaro or Solus:

https://manjaro.org/

https://solus-project.com/

Or pick another one from the list but nothing Ubuntu based!:

https://distrowatch.com/ :smiley:

If your PC has Windows on it, try the HP support tool:

http://www8.hp.com/us/en/campaigns/hpsupportassistant/hpsupport.html :smiley:

Incidentally, I had a USB live disc with Kubuntu 18.04 lying around that I tried to boot from (probably an alpha or beta release). From this, the wireless worked when I selected the broadcom driver. I rebooted back into Mate after verifying that the wifi worked, but I still get the same issues/errors from Mate. Conclusion so far: it’s not a hardware issue, at least.

However, I’m still completely lost as to how to resolve the situation…

Did you at least install the package we talked about earlier?. Have you tried booting the UM 18.04 Live Cd again and see if it works directly from that without problems?. Did you tick the boxes at install time (Install this third-party software)?:

:smiley:

Sorry for this late reply. Anyway, the issue was resolved by installing Mate 18.04.

1 Like