Mate 19.10 - Menus Missing In Application For Some Active Panels

When I activate some panel layouts I've found that the menu and contextual menus don't populate as expected. This is not for all applications but it seems it might be just those using QT.

Two affected applications I've noticed this with:
KeepassX (note that KeepassXC is fine)

The panel layouts that DO NOT show the menu are:

The panel layouts that DO show the menu are:

I am running Ubuntu 19.10 with the latest updates as of now.
This is running on an Intel(R) Core(TM) i5-8600K CPU @ 3.60GHz with a Nvidia - GeForce GTX 1660 Ti with the nvidia-driver-435.

I can't reproduce this issue with a fresh install of Ubuntu Mate 19.10 and applying all the updates.

Any ideas on what I can do to resolve this without re-installing? This wouldn't be a huge deal but would be nice to know why this is happening.


Is the menu bar missing entirely, or is it showing in the wrong place?

If the former problem, it's likely a package surrounding the appmenu library is missing or needs reinstalling so it can reconfigure itself again.

Try re-installing these packages:

sudo apt install --reinstall appmenu-registrar mate-applet-appmenu vala-panel-appmenu-common

:bulb: There was once a appmenu-qt package, but that's for 16.04 and older.

If GTK applications were concerned, then in addition:

sudo apt install --reinstall appmenu-gtk-module-common appmenu-gtk2-module appmenu-gtk3-module libappmenu-gtk2-parser0 libappmenu-gtk3-parser0 

:point_up: These packages are pre-installed on 19.10 for mate-applet-appmenu which provides this menu bar integration into the panel.

Once installed, reset the panel by changing it in :desktop: MATE Tweak.

Although... on my 19.10 system (last updated 4th Jan), KeePassX (Qt) is showing in the wrong spot:

But on 20.04, it's in the right spot:

1 Like

The menu bar itself is fine. The problem is when I click on any of the menu bar items and the population of the dropdown menu text in the aforementioned panels.

I have the adapta theme enabled here but I've tried changing to the default themes.

I've discovered I'm only affected by this issue when I have an additional screen plugged into my graphics card.

As it happens I've always had problems with my multi-monitor set up. My primary screen is a 24" DELL and the secondary screen is a 40" Samsung TV which is used for multi-media only. Despite having the DELL set-up as the default/primary screen some applications (git kraken was a prime example) will still default to opening on the secondary screen.

Now I'm wondering if KeepassX is trying to create the menu dropdown on the secondary screen. The menu is not there but the application definitely does something as the bevahiour changes as though it's waiting for a selection until I press ESC.

Some additional findings and a solution of sorts:

If I turn off the secondary monitor in Monitor Preferences the menu dropdown does populate.

If I turn off the secondary monitor using the NVIDIA X Server Settings the menu dropdown still does not populate.

I have tried the NVIDIA 430 driver. No change.

I have tried the two Marco compositors. No change.

Enabling Compiz .... the dropdown menu populates! :astonished: