Mate 20.04 Freezes gets black or white screen

Hi guys
I read aroud similar topics but I didn't find my problem and I have to hard shut down my pc. Before I used ubuntu 18.04 and I didn't get this problem however I had a different monitor.
This comes from inxi -Fxxz,

Kernel: 5.4.0-51-generic x86_64 bits: 64 compiler: gcc v: 9.3.0
Desktop: MATE 1.24.0 wm: marco dm: LightDM
Distro: Ubuntu 20.04.1 LTS (Focal Fossa)
Type: Desktop Mobo: ASUSTeK model: M5A78L-M LX3 v: Rev X.0x
serial: BIOS: American Megatrends v: 1201 date: 04/19/2013
Topology: 6-Core model: AMD FX-6100 bits: 64 type: MCP arch: Bulldozer
rev: 2 L2 cache: 2048 KiB
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
bogomips: 39777
Speed: 1414 MHz min/max: 1400/3300 MHz Core speeds (MHz): 1: 1453 2: 1410
3: 1520 4: 1555 5: 1446 6: 1410
Device-1: AMD RS780L [Radeon 3000] vendor: ASUSTeK driver: radeon
v: kernel bus ID: 01:05.0 chip ID: 1002:9616
Display: x11 server: X.Org 1.20.8 driver: ati,radeon
unloaded: fbdev,modesetting,vesa compositor: marco
resolution: 1920x1080~60Hz
OpenGL: renderer: AMD RS780 (DRM 2.50.0 / 5.4.0-51-generic LLVM 10.0.0)
v: 3.3 Mesa 20.0.8 compat-v: 3.0 direct render: Yes
Device-1: AMD SBx00 Azalia vendor: ASUSTeK M5A78L LE driver: snd_hda_intel
v: kernel bus ID: 00:14.2 chip ID: 1002:4383
Sound Server: ALSA v: k5.4.0-51-generic
Device-1: Qualcomm Atheros AR8161 Gigabit Ethernet vendor: ASUSTeK
driver: alx v: kernel port: ec00 bus ID: 02:00.0 chip ID: 1969:1091
IF: enp2s0 state: down mac:
Device-2: Qualcomm Atheros AR2417 Wireless Network Adapter [AR5007G
driver: ath5k v: kernel port: ec00 bus ID: 03:05.0 chip ID: 168c:001d
IF: wlp3s5 state: up mac:
Device-3: Ralink MT7601U Wireless Adapter type: USB driver: mt7601u
bus ID: 2-2:3 chip ID: 148f:7601
IF: wlx20e5170dc549 state: up mac:
Local Storage: total: 1.13 TiB used: 50.44 GiB (4.4%)
ID-1: /dev/sda vendor: Kingston model: SA400S37240G size: 223.57 GiB
speed: 3.0 Gb/s serial: temp: 36 C
ID-2: /dev/sdb vendor: Western Digital model: WD10EZRX-00A8LB0
size: 931.51 GiB speed: 3.0 Gb/s serial: temp: 36 C
ID-1: / size: 218.57 GiB used: 50.44 GiB (23.1%) fs: ext4 dev: /dev/sda5
System Temperatures: cpu: 42.0 C mobo: 42.0 C
Fan Speeds (RPM): cpu: 2626 case-1: 0
Voltages: 12v: 12.24 5v: N/A 3.3v: 3.32 vbat: N/A
Processes: 239 Uptime: 3m Memory: 7.51 GiB used: 1.27 GiB (16.8%)
Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Shell: bash
v: 5.0.17 running in: mate-terminal inxi: 3.0.38

First off, welcome to the Ubuntu MATE Community @hector.

When does 20.04 freeze? Does it freeze sporadically or predictably, and at what point? Shutdown? Startup? After you log in?

Well, it happen just after I installed a fresh copy of mate 20.04 , I spend the time trying to get ready to work so it allways crushed while a I got my mozilla surfing the net. I am not sure if it happed when if was off. I just oppened a session as invited and I leave the pc on to see if it freezs


This idea often is a good workaround for graphics trouble these days. Disable Marco compositing (I'll explain what that is in a moment):

  1. Go to the System menu -> Preferences -> Look & Feel -> MATE Tweak. (It may be named something else if you're not running in English mode.)

  2. In the left tab bar in that window, select "Windows".

  3. In the right pane in the window, under the label "Window manager", choose "Marco (no compositing)".

  4. This will make the screen blink briefly. Close that window when the screen has stopped blinking.

I've noticed lately that compositing window managers -- basically window managers which draw effects like shadows on the desktop (although that's a great oversimplification of compositing window managers) -- tend to cause some graphics hardware to go haywire. I guess it's either programming bugs or the usage of features of the graphics hardware not intended to be used.

Either way, I hope that works well enough -- keep me posted on how it does!

Hi, I did it....but It went on white screen again

I just follow step by step this : System Freeze Up
So I will wait if it works fine

it doesn't work either. Well, it seems I will be back to ubuntu 18.04 :man_facepalming: :man_shrugging: