MATE 20.04 Headphone / Mic combo jack not detecting headset

Fresh install of 20.04 Dell P5520 Laptop w/ combo jack. Headset does not work when plugged in. Discovered needing to change the pulseaudio input setting from "Microphone" to "Headset microphone".

It's as if the system is defaulting to "Microphone", or it is not detecting that both headphones and mic are connected and it should change to "Headset microphone".

If headphone plugged in = yes & if Microphone plugged in = yes, then set output = Headphones & Input = "Headset microphone".

I am no expert on pulseaudio, but since I get no sound output until I change the input to the correct one, I feel like there is a sound profile being incorrectly selected when the headset is connected.

I have not been able to find a solution, changing settings in the ALSAMIXER doesn't help.

I read there used to be a sound-switcher, which I don't get prompt for. It would make sense for the system to ask if you connected headphone or a headset.

Does anyone know how I can change / fix this?

Thanks for the help.

New Development:

I added an additional user to the system.
Tested the headset for that user and it works fine as long as my user (original account) is not logged in.
If I log off my user the other user will have sound through the headset.
If both users are logged in both users have no sound through the headset.
If I log off the additional user, I have no sound no matter what I try of my account.

I am going to try and delete my original account and recreate it. I will post back what I discover.

Removed the original account through the GUI, rebooted the laptop.
Slick greeter shows the original account, but you can't log in and the indicator panel shows it as well when you click the power icon.

Secondary account now has no sound through the headset.

Restarted the laptop
After reboot the sound is globally muted.
Headset does not work after un-muting.

Is the "Connector" set to headphones in Sound Preferences > Output > Connector?:

And the Microphone in input:

1 Like

Yes the Output Connector is set to Headphone.
Input was set to "Microphone" I just notice the volume was reduced to 0 when I plugged in the headphones.

  1. I raised the volume
  2. I switched the input from "Microphone" to "Headset Microphone"

I now have sound, but it will reset when I unplug then reconnect the headset.
I then have to change it to "Internal Microphone" to get the sound back.
I then can change it to "Headset Microphone" to use the mic. I can't just switch to "Headset Microphone". I would not get the sound back.

Its been really goofy.

Looks like I have found 2 issues.
A. Headset sound with a combo Jack
B. Shadow users in slick Greeter and the Indicator after the account has been removed.

I fixed the slick-greeter. :grin:
I checked the User/Accounts and the Original account was still listed. I am not sure why it came back,or was re-listed under users. I checked /home and there is no home. I removed it again and restarted.

The account didn't return. :smirk:

Still have an issue with the sound.
Created a new user.
Sound is globally muted and set to 0 at first login.
Connect headset to combo jack and receive no sound
Change input connector to "Headset Microphone": No Sound
Change the input connector to "Internal Microphone": Sound
Change input connector back to "Headset Microphone": Sound
Switch user test
Connect headset to combo jack and sound is muted and volume set to 0
Un-muted and raised volume: still no sound
Change the input connector to "Internal Microphone": Sound
Change input connector back to "Headset Microphone": Sound

Try changing your update sources to "Main" if it isn't set to that already and run updates again!: :grinning:

It is also possible that you have some broken or missing files, you can check that too if you read through the guide!. :grinning:

Thanks for the tip. Since, this was a fresh 20.04 install, I think the update sources were set correctly.
I did install Fedora MATE ReSpin, and the sound was fine. I will have to come back to this when I have time. Hopefully it will be a non-issue by then. I'll check the guide out an see if I missed something. :grin:

1 Like